thắc mắc Cần mn giúp tư vấn lắp đặt lại mạng trong gia đình

greenworm179

Senior Member
Tình hình là nhà mình có hệ thống mạng như sau:

1658677710364.png


Mình có 2 vấn đề:

1. Đôi lúc người nhà rút nhầm điện con Switch 1, xong sau đó cắm lại thì 3 con Router 2 3 4 đều connect fail hoặc connect đc mà không có mạng, check client list của con Router 1 cũng ko hiện con nào cả. Sau khi reset cả Modem, Router 1 2 3, Switch 1 thì vẫn không được (Router 1 phát wifi và PC kết nối thì vẫn bình thường)

2. Đôi lúc (hiếm) lại mất mạng ở Router 4 (ở nhà hàng xóm) reset thế nào cũng không được, xong hôm sau thì lại thấy chạy được bt :ops:
Mong anh em chỉ giúp mình vấn đề mình hậu tạ ly cà phê, mình cám ơn nhiều :beauty:

P/s: ngoài ra còn 1 vấn đề mình muốn hỏi, hiện tại con Router 1 đang cấp phát DHCP cho cả hệ thống, vậy nếu bridge xong để con Router 1 quay Pppoe thì có lợi ích gì không nhỉ mọi người? Mình có đọc qua mà chưa hiểu lắm mong được giải đáp :)
 
Last edited:

rjshkkj

Senior Member
Mạn phép đoán con Router này là con phát wifi kiêm router đúng không?
Nếu đúng thì có thể đổi con Modem thành chế độ Bridge mode rồi dùng Router 1 tạo internet + cấp phát DHCP + wifi (nếu số lượng wifi không nhiều). Từ các cổng của nó còn lại (thông thường 4 cổng) sẽ cấp internet cho PC qua LAN1, L2 xuống switch.
Từ swtich đi đến các con Router/Wifi khác vào cổng WAN để giảm tải cho Router 1.
Làm xong thử dùng máy tính kết nối với con router lớp dưới như 2,3 chẳng hạn ping thử ra ngoài internet xong rồi tắt con switch đi rồi bật lại xem một lát sau nó kết nối lại được không?
Nên tắt sóng, dịch vụ của con modem nhà mạng khi trong nhà có nhiều thiết bị, vì con đó nó kiêm nhiều thứ nên thực sự không khoẻ đáng tin cậy.
 

sakuza.199x

Senior Member
Theo những gì bác mô tả và với những sự cố mình thường hay gặp thì mình có vài điều sau:
- Tình trạng này đa phần là do bác ko quy hoạch lại Ip và cấp DHCP sai cách. Vì một lý do nào đó mà client đang dùng có ip trùng với IP của 1 trong các con router nên mạng tạch ở các node đó.
Bác thử config theo như mình khuyến nghị bên dưới xem tình trạng thế nào.
B1/
-Brigde mode con modem nhà mạng, chuyển con R1 quay pppoe.( tắt hay mở wifi thì tùy thím). bật DHPC cấp từ 192.168.1.20/24 - 192.168.1.250/24.
  • Kéo LAN từ R1 sang S1 ( switch ) và kéo lan to PC.
  • trên R 2 3 4 sẽ connect từ R1 qua S1 dạng LAN to WAN. chuyển chế độ dynamic ip trên các R 2 3 4 sang static ip. thím set lần lược cho nó là 192.168.1.2 (R2), 192.168.1.3(R3), 192.168.1.4 (R4). trên tất cả các R2 3 4 bật DHCP cấp các dãi 192.168.2.1, 192.168.3.1, 192.168.4.1.
=> Ngoài ra cẩn thận quá mức thì bác cấp địa chỉ ip cứng của static ip cho R2 3 4 theo địa chỉ MAC theo đúng dãi ip mình nói ở trên.
Khả năng chịu tải thì mình chưa bàn tới vì thím thớt không nhắc tới số lượng client và nhu cầu sử dụng.
 

greenworm179

Senior Member
Mạn phép đoán con Router này là con phát wifi kiêm router đúng không?
Nếu đúng thì có thể đổi con Modem thành chế độ Bridge mode rồi dùng Router 1 tạo internet + cấp phát DHCP + wifi (nếu số lượng wifi không nhiều). Từ các cổng của nó còn lại (thông thường 4 cổng) sẽ cấp internet cho PC qua LAN1, L2 xuống switch.
Từ swtich đi đến các con Router/Wifi khác vào cổng WAN để giảm tải cho Router 1.
Làm xong thử dùng máy tính kết nối với con router lớp dưới như 2,3 chẳng hạn ping thử ra ngoài internet xong rồi tắt con switch đi rồi bật lại xem một lát sau nó kết nối lại được không?
Nên tắt sóng, dịch vụ của con modem nhà mạng khi trong nhà có nhiều thiết bị, vì con đó nó kiêm nhiều thứ nên thực sự không khoẻ đáng tin cậy.
- Cám ơn bác, đúng là 4 con đều là wifi router bác ạ, chính xác là con TP Link AX10, mình thấy cũng khá khỏe nên trước giờ đang làm đúng như bác nói - con R1 đang đảm nhiệm cấp phát DHCP, chỉ là từ modem thì chưa chuyển chế độ bridge mà mình cắm vào WAN của R1. Con Modem thì mình tắt phát wifi rồi, h nó chỉ cấp IP cho đúng con R1.

Theo những gì bác mô tả và với những sự cố mình thường hay gặp thì mình có vài điều sau:
- Tình trạng này đa phần là do bác ko quy hoạch lại Ip và cấp DHCP sai cách. Vì một lý do nào đó mà client đang dùng có ip trùng với IP của 1 trong các con router nên mạng tạch ở các node đó.
Bác thử config theo như mình khuyến nghị bên dưới xem tình trạng thế nào.
B1/
-Brigde mode con modem nhà mạng, chuyển con R1 quay pppoe.( tắt hay mở wifi thì tùy thím). bật DHPC cấp từ 192.168.1.20/24 - 192.168.1.250/24.
  • Kéo LAN từ R1 sang S1 ( switch ) và kéo lan to PC.
  • trên R 2 3 4 sẽ connect từ R1 qua S1 dạng LAN to WAN. chuyển chế độ dynamic ip trên các R 2 3 4 sang static ip. thím set lần lược cho nó là 192.168.1.2 (R2), 192.168.1.3(R3), 192.168.1.4 (R4). trên tất cả các R2 3 4 bật DHCP cấp các dãi 192.168.2.1, 192.168.3.1, 192.168.4.1.
=> Ngoài ra cẩn thận quá mức thì bác cấp địa chỉ ip cứng của static ip cho R2 3 4 theo địa chỉ MAC theo đúng dãi ip mình nói ở trên.
Khả năng chịu tải thì mình chưa bàn tới vì thím thớt không nhắc tới số lượng client và nhu cầu sử dụng.
- Cám ơn thím, mình cũng nghĩ tới trường hợp trùng IP nên mới reset, mà reset xong thì lúc giải quyết được lúc không nên hơi thắc mắc, còn hôm lâu rồi gặp trường hợp case 1 như mình nêu trên thì đến chịu, thử cắm lại dây ở R1, S1, R4, xong reset các thứ mà R4 vẫn không có tín hiệu, bằng một cách nào đấy trưa hôm sau nó tự kết nối bình thường :beat_plaster:

- Con R1 với PC mình thì ở 1 tầng, còn S1 và R2 1 tầng, R3 R4 1 tầng khác nên ko kéo LAN từ S1 sang PC đc bác. R2 3 4 thì mình đều đang cho cấp phát DHCP ở các dải khác nhau rồi, chỉ chưa set static ip trên R1 cho chúng nó.
- Nhà mình + hàng xóm chỉ tầm 15-20 thiết bị, riêng R4 chiếm <= 8 thiết bị.
Vụ bridge mode thì mình đang thắc mắc như ở #1 mình có đề cập ở trên nên chưa thử, để mình làm theo thím xem sao.
P/s: 2 thím có dùng momo hay ngân hàng nào ib mình mình mời ly cafe với nhé :beauty:
 

sakuza.199x

Senior Member
- Cám ơn bác, đúng là 4 con đều là wifi router bác ạ, chính xác là con TP Link AX10, mình thấy cũng khá khỏe nên trước giờ đang làm đúng như bác nói - con R1 đang đảm nhiệm cấp phát DHCP, chỉ là từ modem thì chưa chuyển chế độ bridge mà mình cắm vào WAN của R1. Con Modem thì mình tắt phát wifi rồi, h nó chỉ cấp IP cho đúng con R1.
Thím check lại xem dãi dhcp của modem đang phát có trùng với con R1 đang phát không? thường modem sẽ là 192.168.1.2 trở đi. và R1 nếu mặc định "thường" nó cũng sẽ phát dãi này. nếu chưa brigde modem thì bác tắt dhcp trên modem rồi set ip cho R1 cùng dãi với modem là được. vd: 192.168.1.2 rồi cho nó cấp dhcp sang dãi khác vd: 192.168.0.20 ( nếu set R1 từ .0.2 thì bác set lại static ip của R2 3 4 thành 192.168.0.3 (R2), 192.168.0.4 (R3), 192.168.0.5(R4).)

- Cám ơn thím, mình cũng nghĩ tới trường hợp trùng IP nên mới reset, mà reset xong thì lúc giải quyết được lúc không nên hơi thắc mắc, còn hôm lâu rồi gặp trường hợp case 1 như mình nêu trên thì đến chịu, thử cắm lại dây ở R1, S1, R4, xong reset các thứ mà R4 vẫn không có tín hiệu, bằng một cách nào đấy trưa hôm sau nó tự kết nối bình thường :beat_plaster:

- Con R1 với PC mình thì ở 1 tầng, còn S1 và R2 1 tầng, R3 R4 1 tầng khác nên ko kéo LAN từ S1 sang PC đc bác. R2 3 4 thì mình đều đang cho cấp phát DHCP ở các dải khác nhau rồi, chỉ chưa set static ip trên R1 cho chúng nó.

Srr thím mình viết chưa rõ. bác có thể kéo LAN từ R1 hoặc từ S1 tới PC đều được. cái này ko quang trọng.
- Nhà mình + hàng xóm chỉ tầm 15-20 thiết bị, riêng R4 chiếm <= 8 thiết bị.
Vụ bridge mode thì mình đang thắc mắc như ở #1 mình có đề cập ở trên nên chưa thử, để mình làm theo thím xem sao.
P/s: 2 thím có dùng momo hay ngân hàng nào ib mình mình mời ly cafe với nhé :beauty:

Mình note bên trên luôn cho tiện theo dõi nha. Mục đích mình khuyến nghị set từ .20 là để dhcp nó k đụng tới static ip của mấy cục R.
 

greenworm179

Senior Member
Mình note bên trên luôn cho tiện theo dõi nha. Mục đích mình khuyến nghị set từ .20 là để dhcp nó k đụng tới static ip của mấy cục R.
Vụ trùng dải thì mình có biết nên set các dải khác nhau cho từng con rồi thím ợ, Modem R1 R2 R3 R4 đều ở các dải khác nhau, PC thì mình đang nối LAN từ R1, coi như R1 và PC chưa bao h gặp sự cố gì, chỉ có đúng mấy con R2 3 4 =((
Để khuya nay mình sẽ nghịch vụ bridge mode và chỉnh static ip dùng 1 thời gian xem có ổn định hơn không.
 

yellow_submarine

Senior Member
Nêu case của mình để bác tham khảo, do khá tương đồng.
Con modem chuyển về bridge. r1 gánh toàn bộ.
  • R1 cấp DHCP cho toàn mạng, chỉ trong dải 70 số, ví dụ từ 192.168.1.2-72.
  • r2, r3, r4 gán Ip cố định, ngoài dải trên để dễ quản lý, ví dụ, 192.168.1.101, 102, 103; đồng thời chuyển hết về dạng AP, chỉ phát wifi. Thế là gọn nhất.
Theo hướng này thì toàn bộ ip được cấp sẽ chỉ trong dải 70 số, dễ quản lý, dễ blacklist nếu cần. Tuy nhiên, con r1 cần phải cân được, chứ yếu xìu thì thôi.
Mình theo kiểu trên chạy 2 năm nay chưa gặp vấn đề gì. router 1 hồi đầu dùng pfsense, giờ đang chạy mik hap ac2; clients khoảng 20-30 cao điểm đồng thời (do tầng 1 có cho thuê, để một wifi guest free); mạng 100mb vnpt.; 2 switch giga (tầng 1, 2); 3 AP mỗi tầng 1 con (1 aruba 325+2 aruba 225), chạy lan từ switch ra.
 

rjshkkj

Senior Member
Vụ trùng dải thì mình có biết nên set các dải khác nhau cho từng con rồi thím ợ, Modem R1 R2 R3 R4 đều ở các dải khác nhau, PC thì mình đang nối LAN từ R1, coi như R1 và PC chưa bao h gặp sự cố gì, chỉ có đúng mấy con R2 3 4 =((
Để khuya nay mình sẽ nghịch vụ bridge mode và chỉnh static ip dùng 1 thời gian xem có ổn định hơn không.
Việc thiết lập IP cấp dưới qua WAN là nhàn nhất nó giảm tải cho tuyến trên và cách ly với tuyến trên nữa. Mình lắp đặt mạng nhiều hay chơi kiểu đó và chỉ xài qua LAN khi tuyến dưới muốn cùng cấp tuyến trên để xài chung dịch vụ chia sẻ, in ấn. Nói chung qua WAN hay qua LAN cũng ổn định hầu như không có vấn đề gì khi có sự cố mất điện gì đó thì chỉ vài phút sau nó sẽ cấp lại IP xuống dưới.
Bạn thử bằng cách tạo các tình huống mất điện ở switch rồi có điện swich trong khi dùng máy tính xách tay, để bàn tuyến dưới ping ra ngoài internet xem có thông được không, thông thường tắt switch rồi bật lại thì chưa đầy 1-2 phút sau mạng tự động kết nối lại.
Lưu ý nhỏ ở đây là cái switch, switch nhiều khi có lỗi bất tử, bạn có thể kiếm con switch khác thay vào thử xem sao.
Sáng nay cũng đi xử lý mạng 1 con switch lỗi cổng, cắm cổng khác OK còn cổng đó chập chờn ma làm, đèn báo switch sáng, đèn thiết bị báo tốt nhưng không có mạng, cắm cổng khác thì bình thường.
 

greenworm179

Senior Member
Nêu case của mình để bác tham khảo, do khá tương đồng.
Con modem chuyển về bridge. r1 gánh toàn bộ.
  • R1 cấp DHCP cho toàn mạng, chỉ trong dải 70 số, ví dụ từ 192.168.1.2-72.
  • r2, r3, r4 gán Ip cố định, ngoài dải trên để dễ quản lý, ví dụ, 192.168.1.101, 102, 103; đồng thời chuyển hết về dạng AP, chỉ phát wifi. Thế là gọn nhất.
Theo hướng này thì toàn bộ ip được cấp sẽ chỉ trong dải 70 số, dễ quản lý, dễ blacklist nếu cần. Tuy nhiên, con r1 cần phải cân được, chứ yếu xìu thì thôi.
Mình theo kiểu trên chạy 2 năm nay chưa gặp vấn đề gì. router 1 hồi đầu dùng pfsense, giờ đang chạy mik hap ac2; clients khoảng 20-30 cao điểm đồng thời (do tầng 1 có cho thuê, để một wifi guest free); mạng 100mb vnpt.; 2 switch giga (tầng 1, 2); 3 AP mỗi tầng 1 con (1 aruba 325+2 aruba 225), chạy lan từ switch ra.
Đúng là case giống mình này, lúc đầu mình cũng setup giống bác để quản lý cho tiện (trừ R4 do ở nhà hàng xóm), có đợt mình gặp lỗi với mode AP của con R2 R3 nên từ đó cho nó tự cấp phát DHCP luôn. Để lên xem có update firmware mới fix lỗi chưa với chắc qua hàng xóm đàm phán để chuyển mode AP luôn quá.
Con R1 của mình là TPLink AX10, ko phải router công nghiệp nhưng m thấy cũng khá khỏe, tầm tối đa 20 thiết bị (tải đồng thời thì ~ 10-15) thì thấy không sao nên chắc ok.

Cám ơn ý kiến bác nhiều, ib momo /stk mình mời cà phê nhé bác :beauty:
 

greenworm179

Senior Member
Việc thiết lập IP cấp dưới qua WAN là nhàn nhất nó giảm tải cho tuyến trên và cách ly với tuyến trên nữa. Mình lắp đặt mạng nhiều hay chơi kiểu đó và chỉ xài qua LAN khi tuyến dưới muốn cùng cấp tuyến trên để xài chung dịch vụ chia sẻ, in ấn. Nói chung qua WAN hay qua LAN cũng ổn định hầu như không có vấn đề gì khi có sự cố mất điện gì đó thì chỉ vài phút sau nó sẽ cấp lại IP xuống dưới.
Bạn thử bằng cách tạo các tình huống mất điện ở switch rồi có điện swich trong khi dùng máy tính xách tay, để bàn tuyến dưới ping ra ngoài internet xem có thông được không, thông thường tắt switch rồi bật lại thì chưa đầy 1-2 phút sau mạng tự động kết nối lại.
Lưu ý nhỏ ở đây là cái switch, switch nhiều khi có lỗi bất tử, bạn có thể kiếm con switch khác thay vào thử xem sao.
Sáng nay cũng đi xử lý mạng 1 con switch lỗi cổng, cắm cổng khác OK còn cổng đó chập chờn ma làm, đèn báo switch sáng, đèn thiết bị báo tốt nhưng không có mạng, cắm cổng khác thì bình thường.
- Mình cũng nghi con switch nhưng hôm lâu thay con khác thì vẫn bị thế nên chắc không phải, mình cũng hiểu vụ cấp phát IP của tuyến dưới theo đúng hướng như bác, giảm tải cho con R1.
- Con R2 mình có kết nối với 1 PC khác thì những lúc lỗi là cũng tịt luôn, và đang có vài con camera kết nối bằng LAN tới R2 nên mình cũng không biết có phải tụi nó là nguyên nhân gây lỗi không, do đám camera này không phải mình quản lý nên cũng chưa test tường tận được :cry:.
 

greenworm179

Senior Member
Chốt lại tối nay mình sẽ thử bridge, set IP tĩnh cho R234 chạy xem sao, cuối tuần chuyển hết R234 về AP mode cho R1 quản hết rồi xem xét tình hình thử.
Để sắp tới mua thêm 1 con router khác mesh Lan với con R1, lược bỏ 2 3 4 luôn chắc sẽ đỡ lỗi.
Cám ơn ae rất nhiều :love:
 

greenworm179

Senior Member
À ae cứ mạnh dạn ib mình momo/stk nhé, của ít lòng nhiều, mời ae ly cà phê đổi lấy kiến thức chứ không lấy info gì đâu ae đừng sợ :adore:
 

sakuza.199x

Senior Member
  • Mình cũng nghi con switch nhưng hôm lâu thay con khác thì vẫn bị thế nên chắc không phải, mình cũng hiểu vụ cấp phát IP của tuyến dưới theo đúng hướng như bác, giảm tải cho con R1.
  • Con R2 mình có kết nối với 1 PC khác thì những lúc lỗi là cũng tịt luôn, và đang có vài con camera kết nối bằng LAN tới R2 nên mình cũng không biết có phải tụi nó là nguyên nhân gây lỗi không, do đám camera này không phải mình quản lý nên cũng chưa test tường tận được :cry:.
Morning thím.
Từ đầu mô hình thím ko đề cập tới đám camera.
vậy nên mình càng có lý do để khuyến khích bác chạy LAN to WAN tới toàn bộ các R2 3 4 như mình nói bên trên. Mình học được nhiều từ các bác chuyên đi lắp cam trên này là ko bao giờ cắm trực tiếp cam vào router đang dùng chung với thiết bị khác cả. theo như bác nói trên thì bác đang để mode AP trên R2 và khi camera hoạt động ( realtime) nó sẽ chiếm rất lớn băng thông. việc đàm phán hàng xóm để chuyển mode con R4 thì đơn giản thôi thím.
 

greenworm179

Senior Member
Morning thím.
Từ đầu mô hình thím ko đề cập tới đám camera.
vậy nên mình càng có lý do để khuyến khích bác chạy LAN to WAN tới toàn bộ các R2 3 4 như mình nói bên trên. Mình học được nhiều từ các bác chuyên đi lắp cam trên này là ko bao giờ cắm trực tiếp cam vào router đang dùng chung với thiết bị khác cả. theo như bác nói trên thì bác đang để mode AP trên R2 và khi camera hoạt động ( realtime) nó sẽ chiếm rất lớn băng thông. việc đàm phán hàng xóm để chuyển mode con R4 thì đơn giản thôi thím.
Morning bác,
Đúng là hôm qua mình quên đề cập việc này, nhưng mà đám camera đc cắm riêng vào 1 con đầu thu (mình không chắc gọi đúng tên không), xong từ đầu thu mới cắm vào R2, thì liệu như thế này có ảnh hưởng không nhỉ bác?
Hôm qua thì mình vừa đổi R4 qua AP mode r, tạm thời đang ổn định, mình đang theo dõi thêm xem tải con R1 có gì bất thường không.
 

gaixixon

Senior Member
bác thớt cho em hỏi ké các chuyên gia với ạ.
Em có kết nối như thế này:
Modem(LAN)-->(Internet/WAN)Router 1(LAN port)---->(WAN Port)Router 2(LAN Port)------->(WAN Port)Router 3... -> router 4 .. router n..
Các router được nối với nhau bằng dây LAN (2 đầu bấm giống nhau)
Tạm coi các router có chất lượng giống nhau, dây mạng tốc độ kết nối cao nhất.

Câu hỏi của em là:
1. Tốc độ mạng của thiết bị nối với router 3, router 4.. so với thiết bị nối với router 1 có tốc độ internet chênh lệch nhiều không? (Nhiều ở đây ý em là giảm 1 nửa gì đó, chứ vài Mb/s coi như không đáng kể)

2. Các router em đang để DHCP, lần lượt là 192.168.1.1 (router 1); 192.168.2.1 (router 2) ... 192.168.n.1 (router n).
2a: Em có thể để thằng router 2 có địa chỉ "khác người" là 10.0.0.2 có được không? (Các thằng còn lại vẫn 192.168.n.1).
2b: Việc em disable DHCP có làm tăng tốc độ mạng (so với việc để DHCP) không? (Tất nhiên disable DHCP thì tín hiệu vào của dây LAN sẽ cắm vào cổng LAN, chứ không cắm vào WAN nữa).

3. Dây mạng nối các router này nên bấm thẳng (2 đầu giống nhau), hay bấm chéo?

4. Việc nối nhiều router như trên có làm chậm mạng lại hay không?
(Tầng 1 em có chuỗi router như thế này cắm vào modem: -->(Internet/WAN)Router 1(LAN port)---->(WAN Port)Router 2(LAN Port)------->(WAN Port)Router 3... -> router 4 .. router n..;

Tầng 2 em cũng có một chuỗi -->(Internet/WAN)Router 1(LAN port)---->(WAN Port)Router 2(LAN Port)------->(WAN Port)Router 3... -> router 4 .. router n.. cắm vào chính cái modem bên trên ạ.

5. Cân bằng tải thường được người ta kết nối như thế nào trong một tòa nhà nhiều tầng ạ?

Cảm ơn các bác đã khai sáng.
 
Top