thảo luận Cộng đồng người dùng MikroTik Router

tuanreb

Member
ĐÁNH GIÁ MIKROTIK ROUTER

=> Một số chia sẻ của a/e về MikroTik được cập nhật liên tục ở #3
  • MikroTik là công ty sản xuất thiết bị định tuyến (Router) và các sản phẩm về mạng không dây của Latvia
  • RouterOS là một hệ điều hành mạng dựa trên nền Linux được cài đặt trên các bộ định tuyến MikroTik. RouterOS có thể cấu hình qua giao diện web (WebFig) hoặc sử dụng phần mềm Winbox.
  • Winbox là phần mềm để cài đặt cấu hình sản phẩm, nó sử dụng cả giao diện dòng lệnh và giao diện đồ hoạ trực quan
  • Điều gì làm MikroTik trở nên nổi bật và khác biệt giữa một rừng các nhà sản xuất thiết bị mạng khác. Cấu hình thiết bị khủng hay thiết kế đẹp? Không không hề, điều làm MikroTik hấp dẫn và khác biệt so với những thiết bị khác chính là hệ điều hành RouterOS của hãng, nó có tuỳ chỉnh sâu và làm được nhiều việc hay ho mà những thiết bị của đối thủ khó có thể làm được, điều hấp dẫn hơn nữa là thiết bị của hãng có giá thành vừa phải dễ tiếp cận với mọi người (như thiết bị trong bài đánh giá được tôi mua với giá 850.000 vnđ). Rào cản duy nhất khiến bạn chưa đến với sản phẩm của MikroTik là việc cài đặt, cấu hình thiết bị của hãng có phần hơi phức tạp hơn so với các hãng sản xuất khác
  • Trong bài tôi sẽ đưa ra đánh giá trên quan điểm cá nhân sau một thời gian sử dụng sản phẩm và giúp bạn cấu hình thiết bị một cách đơn giản và cơ bản nhất để bạn có thể sử dụng thiết bị để kết nối internet và làm vài trò vui vẻ với nó

1. Thiết kế và thông số kỹ thuật

20209e8e990e-3110-444f-a2a0-b061f78fae36.jpg


a. Thiết kế
- Bộ sản phẩm gồm một router màu đen, một chân đế bằng nhựa trong suốt, một cục nguồn DC out 24V-800mA (Bạn có thể đặt Router đứng hoặc nằm với chân đế hỗ trợ)
  • Vỏ ngoài router phủ một lớp mềm mềm mượt mượt sờ rất thích tay
  • Phía trước Router là dãy đèn thông báo trạng thái kết nối. Phía trên có 1 cổng USB 2.0 để mở rộng bộ nhớ hoặc kết nối thiết bị thu phát 3G/4G. Phía sau gồm 1 cổng nguồn, một nút reset, và 5 cổng Ethernet được bọc kim loại. Cổng số 1 hỗ trợ cấp nguồn vào PoE, với RouterOS bạn có thể lựa chọn cổng WAN và LAN không bị fix cố định như nhiều hãng khác.
  • Router có kích thước nhỏ gọn, chỉ to hơn bàn tay một chút. Nhìn bề ngoài nhỏ vậy thôi nhưng có võ đấy

b. Thông số kỹ thuật
Details
Product codeRBD52G-5HacD2HnD-TC
ArchitectureARM 32bit
CPUIPQ-4019
CPU core count4
CPU nominal frequency716 MHz
Dimensions34 x 119 x 98mm
License level4
Operating SystemRouterOS
Size of RAM128 MB
Storage size16 MB
Storage typeFLASH
Tested ambient temperature-40°C to 50°C
Suggested price$69.00
Wireless
AC speedAC1200
Wireless 2.4 GHz Max data rate300 Mbit/s
Wireless 2.4 GHz number of chains2
Wireless 2.4 GHz standards802.11b/g/n
Antenna gain dBi for 2.4 GHz2.5
Wireless 2.4 GHz chip modelIPQ-4019
Wireless 2.4 GHz generationWi-Fi 4
Wireless 5 GHz Max data rate867 Mbit/s
Wireless 5 GHz number of chains2
Wireless 5 GHz standards802.11a/n/ac
Antenna gain dBi for 5 GHz2.5
Wireless 5 GHz chip modelIPQ-4019
Wireless 5 GHz generationWi-Fi 5
Ethernet
10/100/1000 Ethernet ports5

2. Khả năng phát sóng Wifi và băng thông
2.1 Khả năng phát sóng wifi

  • HAP AC^2 là thiết bị kết hợp giữa Router và Access Point. Vừa là một thiết bị định tuyến vừa là thiết bị phát sóng Wifi
  • Thiết bị sử dụng SOC - IPQ4019 của Qualcomm sử dụng Wifi 5 AC Wave 2 có hỗ trợ công nghệ MU-MIMO 2x2 (2-stream)
  • Router MikroTik đặt ở tầng 2 và test tại 3 vị trí và thu được kết quả như sau (Gói cước sử dụng VNPT-GD0-60Mbps):

+ Vị trí 1: Bên cạnh Router
2020526fe345-6327-4fd7-8456-711a72509e0f.jpg


+ Vị trí 2: Cách Router 5m qua hai lớp tường 10 gạch lỗ (phòng cùng tầng đặt Router)
202013bdc887-14fe-438d-adfe-93fcbc3a5451.jpg


+ Vị trí 3: Cách 4m qua 1 trần bê tông ~20cm (tầng 3 phía trên phòng đặt Router)
2020130b137c-ace0-4a46-ab29-b407e8fd219b.jpg


=> Khả năng phát sóng Wifi của thiết bị chỉ ở mức Trung bình. Router có thể phủ sóng những ngôi nhà 2 tầng diện tích vừa phải hoặc những chung cư không quá lớn, ít vật cản sóng.

2.2 Băng thông
* Asix AX88179 <===> hAP AC^2


2020d74af1a9-30bc-4517-94b5-f117fa68f7eb.jpg


3. Cấu hình thiết bị
  • Trong bài viết này tôi sẽ cùng bạn đi cài đặt router để thiết bị có thể kết nối internet bằng một địa chỉ IP Public
  • IP Public là IP mà ISP (Nhà cung cấp dịch vụ Internet) cấp cho bạn, nó có thể là IP động hoặc IP tĩnh. IP Public là tài nguyên hữu hạn và bạn phải trả phí để sử dụng. IP Private là IP do thiết bị của người dùng cấp và nó hoàn toàn miễn phí
  • Giao thức kết nối sử dụng trong bài viết là PPPoE (Giao thức điểm tới điểm qua Ethernet). Router của bạn chính là một điểm, điểm còn lại nằm ở phía ISP

Bước 1: Lựa chọn cổng WAN cổng LAN cho thiết bị
  • Mặc định thiết bị không quy định đâu là cổng WAN nên bạn phải lựa chọn cổng WAN cho thiết bị. Bạn có thể sử dụng một cổng bất kì làm cổng WAN, nếu sử dụng nhiều đường truyền Internet bạn có thể chọn thêm một số cổng Ethernet khác làm cổng WAN cũng được
  • Trong bài viết tôi sử dụng một đường truyền Internet nên chọn cổng số 1 làm cổng WAN và 4 cổng còn lại làm cổng LAN. Tôi sẽ nhóm cổng 2,3,4 và 5 vào một nhóm tôi gọi là “LAN Network” bạn không thích có thể đặt tên khác miễn bạn hiểu là được. Thao tác tạo nhóm LAN Network như hình dưới

2020d10f5732-4704-437c-842b-17b594ee0e91.png


- Tạo xong nhóm LAN Network rồi bạn cần đưa cổng 2,3,4 và 5 vào nhóm này. Thao tác thêm cổng 2 vào nhóm Lan Network như hình dưới. Thêm các cổng 3,4 và 5 làm tương tự như với cổng số 2

2020fa43a2dd-2f18-4305-995b-a4832d384ede.png


- Giờ ta sẽ quay lại với cổng số 1 để cấu hình nó thành cổng WAN đi ra Internet

Bước 2: Khai báo thông tin truy cập internet (quay PPPoE)
Tại giao diện winbox: PPP => Interface => “+” => PPPoE Client (Bạn đóng vai trò là PPPoE Client còn ISP là PPPoE Server)

2020212a5409-28bf-42ac-9ddb-90e8aa7a2f56.png


- Cửa sổ Interface PPPoE hiện ra, tại thẻ General mục Interfaces bạn chọn một cổng Ethernet muốn làm cổng WAN, ở đây tôi chọn cổng Ethernet 1/LAN 1 làm cổng WAN để đi ra ngoài Internet

20207b08a9b6-ffde-4715-a67e-dec48520824f.png


Tại thẻ Dial Out bạn nhập Username và Password trong hợp đồng với ISP vào đây và click OK

2020d50f2e14-9c3d-4d63-a7e7-0b20c37e8266.png


-Thế là xong bước khai báo thông tin truy cập Internet

Bước 3 Chọn máy chủ phân giải tên miền DNS
- IP là dãy số, dãy kí tự sắp xếp theo quy tắc nhất định được máy tính sử dụng để tìm địa chỉ. Nhưng con người không thể nhớ và hiểu những dãy số và kí tự đó, thay vào đó con người sử dụng tên miền để tìm kiếm địa chỉ trên internet. Do đó cần có một hệ thống/một máy chủ để phân giải tên miền cho máy tính hiểu được, bằng cách liên kết/gán địa chỉ IP vào tên miền

Tên miền
Địa chỉ IP
Google.com172.217.24.206
Yahoo.com72.30.35.10

=> Máy tính sử dụng IP còn con người sử dụng tên miền để tìm địa chỉ
- Quay lại với MikroTik, bạn cần chọn máy chủ DNS để router lấy thông tin. Trong bài viết này tôi sử dụng DNS của Google vì nó hoạt động tốt và dễ nhớ. Hai máy chủ DNS của Google được sử dụng phổ biến có địa chỉ IP là 8.8.8.8 và 8.8.4.4. Không thích dùng của Google thì có thể sử dụng DNS của CloudFlare có địa chỉ IP là 1.1.1.1 và 1.0.0.1

- Để chọn máy chủ DNS bạn thao tác: IP => DNS => nhập địa chỉ IP máy chủ DNS vào đây. Bạn nhập một địa chỉ DNS hoặc cả hai địa chỉ cũng được không sao cả. Nhưng theo tôi nên nhập cả 2 phòng khi DNS A gặp sự cố còn có DNS B hoạt động, nếu không sẽ làm gián đoạn truy cập internet

20208fedc6e6-fb81-477b-9120-771b6a9f9cd9.png


- Bạn làm xong bước 2 và 3 là bạn đã tạo được con đường để kết nối, vận chuyển dữ liệu từ router ra bên ngoài Internet. Giờ bạn cần tạo con đường để kết nối, vận chuyển dữ liệu từ Router tới các client nội bộ bên trong

Bước 4 Tạo và cấp địa chỉ IP Private cho nhóm LAN Network

  • Công việc tiếp theo bạn cần làm là cấp địa chỉ IP cho từng thiết bị trong hệ thống mạng nội bộ. Lúc này Router sẽ đóng vai trò là Server cấp phát IP cho các thiết bị kết nối đến nó
  • Thao tác như sau: IP => Addresses => “+” => tại Address bạn nhập địa chỉ IP Private bạn muốn. VD: 192.168.1.1/24
  • Tại Interface bạn chọn LAN Network để đặt địa chỉ IP Private cho nhóm mạng Lan này

20208283e829-4ff0-49b0-a3ee-914c82b94759.png


  • Tiếp đến bạn cần sử dụng DHCP để router tự động cấp địa chỉ IP khi có client kết nối vào các cổng trong nhóm LAN Network
  • IP => DHCP Server => DHCP Setup => DHCP Server Interface => bạn chọn nhóm LAN Network để Router cấp địa chỉ IP tự động cho cả nhóm LAN Network. Sau đó thì next liên tục cho đến khi kết thúc

2020f6e64bbe-8830-404e-9ba9-1dd470bbd95d.png


  • Xong bước 4 là bạn đã tạo được con đường để kết nối Router đến từng client trong mạng nội bộ
  • Con đường từ router ra ngoài internet và con đường từ router đến các thiết bị trong mạng nội bộ đã xong vậy các thiết bị trong mạng nội bộ đã ra ngoài internet được chưa? Trả lời bạn là vẫn chưa đâu vẫn còn bước cuối cùng là NAT (biên dịch địa chỉ mạng)

Bước 5 Biên dịch địa chỉ mạng – NAT
  • Bạn hiểu một cách đơn giản thì NAT là việc cho nhiều client đi ra ngoài Internet cùng lúc bằng một địa chỉ IP Public và ngược lại
  • NAT dùng IP Puclic để thay thế cho IP Private trong các gói tin từ client chuyển đến router rồi đưa nó ra Internet và chiều ngược lại thì dùng IP Private thay thế cho IP Puclic rồi chuyển nó đến client cần nhận
  • Lý do: Chỉ có IP Public mới có khả năng định tuyến được trong môi trường mạng Internet còn IP Private chỉ định tuyến được trong mạng nội bộ
  • Tất cả các dữ liệu từ client trong mạng nội bộ muốn ra ngoài Internet đều phải đi qua Router. Để định tuyến được dữ liệu thì Router cần thông tin về IP nguồn/MAC nguồn, IP đích/MAC đích và các trường thông tin khác.
  • Router sẽ đứng ra với vai trò là thiết bị trung gian giữa môi trường mạng nội bộ và mạng Internet.
  • Thao tác trên winbox như sau: Chọn IP => Firewall => NAT => “+”
  • Tại thẻ General mục Chain chọn srcnat, mục Out. Interface chọn PPPoE tương ứng với đường line mà bạn muốn NAT

20208a40b0ea-9fa4-4be2-82db-8f2efa043d4d.png


- Tiếp theo bạn qua thẻ Action tại mục Action chọn masquerate
=> Có bao nhiêu đường WAN thì phải thực hiện từng ấy lần NAT

20205c8a8372-ffa4-4a65-9d9c-4695d4f477fb.png


- Giờ thì bạn đã có thể kết nối ra ngoài Internet qua 4 cổng LAN số 2,3,4 và 5

Bước 6: Kích hoạt và sử dụng WIFI
  • Mặc định nhà sản xuất sẽ tắt 2 card mạng Wifi 2.4GHz và 5GHz, bạn cần enable chúng và cấu hình một chút
  • Trong Interfaces hoặc Wireless bạn sẽ thấy chúng bị disable, giờ thì chọn vào chúng và enable nó lên

202045950af8-3c40-40ab-b13a-1653f2c4fefe.png


- Bạn hãy coi 2 mạng Wifi này như 2 cổng LAN. Bạn có thể đưa chúng vào nhóm LAN Network để lấy IP hoặc tạo một nhóm mới cho nó. Tôi sẽ tạo một nhóm mới cho nó gọi là WIFI Network và đưa 2 mạng Wifi này vào trong đó như cách tôi đưa cổng số 2,3,4 và 5 vào nhóm LAN Network

Tạo nhóm WIFI Network

2020be65087c-b8c4-4e2e-9311-f58345e17433.png


Đưa 2 card mạng WIFI vào trong nhóm WIFI Network

202042e387d1-3894-4b77-976b-8f011801f1b9.png


Tạo Password cho nhóm WIFI Network


20203cf2e308-d4a1-4af8-b0f8-11fd3b5068cb.png


- Để cấp địa chỉ IP cho nhóm này bạn làm tương tự như bước 4 bên trên. Chỉ thay LAN Network thành WIFI Network và đặt IP của 2 nhóm này khác nhau tránh bị trùng

- Việc cài đặt Wifi giống như các thiết bị phát sóng Wifi khác bạn cần chọn SSID, Password, Độ rộng kênh, Số kênh... bạn tham khảo cấu hình bên dưới, những phần bôi đỏ là những phần bạn cần lưu ý (Tôi demo với băng tần 2.4GHz băng tần 5GHz làm tương tự)

20205e5ed58d-eea9-48a3-baad-4c47a20bbae0.png


- Giờ bạn có thể sử dụng WIFI của thiết bị rồi đấy
 
Last edited:

tuanreb

Member
Nếu bạn chỉ thích dùng thứ có sẵn, không thích hiểu đống lý thuyết loằng ngoằng phía trên thì t cũng có giải pháp cho bạn đây

- Bạn xóa hết cấu hình cũ trên thiết bị đi

202163e308a6-3b57-4881-8d27-0836a97d5c7f.jpg


T sẽ để Script config cơ bản của PPPoE ở file text bên dưới, có một số thông tin cá nhân bạn cần chỉnh sửa lại trong file text: Username, Password trong hợp đồng với ISP, SSID và Mật khẩu Wifi . Sau khi sửa xong bạn mở Winbox lên vào New Terminal và Copy/Paste toàn bộ đoạn Script bạn đã chỉnh sửa vào đây và Enter cho nó chạy là xong

202177dca413-02eb-46d7-82f8-0aed76665af1.jpg


4. Chặn Facebook, YouTube
  • Các ông bố/bà mẹ luôn cảm thấy phiền lòng khi con cái họ có sử dụng Facebook, YouTube quá nhiều. Hay công ty không muốn nhân viên xao lãng công việc vì giành thời gian nhiều cho 2 website trên. Trong phần này tôi sẽ cùng bạn thực hiện việc chặn truy cập 2 website này nhé.
  • Để thực hiện việc chặn 2 website trên ta sử dụng công cụ Firewall có sẵn trong hệ điều hành RouterOS
  • Tôi demo thao tác chặn FaceBook trước, với YouTube bạn làm tương tự

Bước 1: Lập danh sách những tên miền cần chặn
- Trong winbox bạn thao tác: IP => Firewall => Layer 7 Protocols => "+"
(Layer 7 Protocols là tầng 7-tầng ứng dụng trong mô hình OSI. Nói cách dân dã để bạn dễ tưởng tượng thì Chrome, Edge hay các trình duyệt web khác hoạt động ở tầng này)
  • Mục name bạn đặt tên cho nhóm tên miền cần chặn. Tôi đặt là Block Facebook bạn không thích có thể đặt tên khác miễn bạn hiểu là được
  • Mục Regexp (Regular Expression) bạn nhập các tên miền cần chặn. Nó có quy tắc nhập để RouterOS hiểu và đọc được, cụ thể như sau: ^..+\.(các tên miền cần chặn).*$ bên trong dấu ngoặc đơn là những tên miền bạn muốn chặn, mỗi tên miền ngăn cách với nhau bằng dấu gạch đứng | (bạn xem hình minh họa bên dưới để rõ hơn)

2021c29e60c7-7879-4663-8420-e927392eb836.jpg


Bước 2: Đưa danh sách những tên miền cần chặn vào Filter Rule để Firewall thực hiện chặn kết nối
- Trong Firewall bạn qua thẻ Filter Rules => "+" => General. Mục chain chọn forward
  • Chain FORWARD: Các rule thuộc chain này áp dụng cho các gói tin chuyển tiếp trong nội bộ hệ thống (VD Giữa router vs client)
  • Chain INPUT: Các rule thuộc chain này áp dụng cho các gói tin từ bên ngoài vào hệ thống
  • Chain OUTPUT: Các rule thuộc chain này áp dụng cho các gói tin đi từ hệ thống ra bên ngoài

20213549b31c-c9c2-4dcd-89f9-15794f30662c.jpg


-Mục Protocol: Chọn cả TCP và UDP vì đây là 2 giao thức cốt lõi trong bộ giao thức TCP/IP. Hầu hết các mạng máy tính thương mại đang chạy trên bộ giao thức này. T demo thao tác chọn giao thức TCP trước

202115f58a7e-91f0-49c1-af4d-63c1cbfc89ec.jpg


Qua thẻ Advanced, mục Layer 7 Protocol (đã giải thích ở bước 1) bạn chọn nhóm tên miền cần chặn đã tạo ở bước 1. Ở đây của tôi là Block FaceBook

2021811ee0fe-e380-47d9-93c0-45d8de752c42.jpg


- Qua thẻ Action, mục Action chọn Drop (chặn kết nối nhưng không thông báo đến client bị chặn) hoặc Reject (chặn kết nối và có thông báo đến client bị chặn). Ở đây tôi chọn Drop
=> Thế là bạn đã thực hiện chặn kết nối từ các tên miền đã lên danh sách ở bước 1, vận chuyển dữ liệu qua giao thức TCP, giờ bạn cũng tạo thêm một Filter Rule tương tự với lựa chọn giao thức UDP (lặp lại 3 thao tác ở bước 2)

Việc chặn YouTube bạn làm tương tự như với FaceBook chỉ khác ở danh sách tên miền cần đưa vào danh sách chặn. Bạn tham khảo hình bên dưới

2021937a0fa5-8421-441a-b13e-dfa1e84dcf42.jpg
 

Attachments

  • PPPoE.txt
    2.9 KB · Views: 352
Last edited:

tuanreb

Member
Chia sẻ của các thành viên VOZ

Các script hay ho dành cho Mikrotik Router.

RouterOS là một hệ điều hành, nên việc bạn có thể tùy biến, thêm các script (đoạn mã) nhỏ hữu dụng giúp công việc của bạn trở nên nhẹ nhàng hơn là điều hết sức bình thường giống như việc bạn mở Google Calendar ra và đặt 25/9/2020 lúc 10h sáng nhắc bạn trưa nay đi uống cafe vậy.

RouterOS sẽ thông báo cho bạn khi một tác vụ được chạy xong qua 02 cách:

  1. Gửi qua email.
  2. Gửi qua tin nhắn Telegram.
Trước tiên các bạn cần cấu hình máy chủ gửi email cho Mikrotik đã nhé. Mình hướng dẫn anh em luôn.

Bước 1
: Sau khi tải winbox ở bước trên, các bạn mở giao diện winbox lên và tiến hành đăng nhập vào Mikrotik router. Mikrotik router có nhiều cách đăng nhập khác nhau, bạn có thể đăng nhập qua IP, qua Mac của thiết bị hoặc qua Cloud đi kèm mỗi thiết bị.
Khi khởi động lên thì Winbox sẽ tự động tìm thiết bị Mikrotik router bạn sử dụng sau đó các thông tin như:
Connect to: Mikrotik sẽ tự điền hộ bạn
Login: username bạn đặt
Password: password bạn chọn

Sau khi bạn điền đủ thông tin thì ấn “connect” nhé, nếu đúng thì qua được bước sau. Còn nếu sai thì chịu với bạn luôn á.

winbox.jpg

Bước 2: Sau khi đăng nhập thành công, các bạn vào “Tools” => “Email” để tiến hành cấu hình máy chủ email nhé. Cấu hình làm gì? Để mỗi khi Mikrotik Router nó thực hiện xong tác vụ được yêu cầu nó sẽ báo cho bạn chứ còn gì nữa.

Trong bảng Email Settings sẽ có các thông số các bạn cần phải điền như sau:
Server: địa chỉ máy chủ gửi mail
Port: 25, 465, hoặc 587 tùy
Start TLS: các bạn chọn YES hoặc NO tùy vào nhà cung cấp dịch vụ
From: gửi từ địa chỉ nào
User: nhà cung cấp dịch vụ sẽ đưa cho bạn
Password: nhà cung cấp dịch vụ sẽ đưa cho bạn

Hiện nay có rất nhiều các dịch vụ cung cấp email miễn phí, các bạn có thể sử dụng như (Sendgrid, Mailgun, Elastic Email). Hoặc đơn giản chỉ là nhu cầu cá nhân thì bạn có thể sử dụng ngay dịch vụ của google trên chính địa chỉ gmail các bạn đang sử dụng á. Còn làm như nào thì anh em google giúp nhé, nhiều bài hướng dẫn lắm.

winbox-cai-dat-email.jpg

C1/ Script giúp bạn tự động sao lưu cấu hình Mikrotik Router và tự động cập nhật phiên bản mới mỗi khi có.

Bước 1: Các bạn làm tuần tự theo hình vẽ nhé, mình đã đánh số rất là trực quan rồi.
Bảng Script thì các bạn có thể đặt tên gì tùy thích. Ko nhất thiết phải đặt giống mình đâu.
Phần 4 là phần script các bạn vào url này copy nhé => https://raw.githubusercontent.com/b...-backup-and-update/master/BackupAndUpdate.rsc

Chỉ lưu ý rằng khi copy các bạn nên sử 1 dòng trước khi vứt vào phần số 4 trong hình minh họa đó là:

:local emailAddress "yourmail@example.com"; => Các bạn chỉnh yourmail thành địa chỉ hòm thư của các bạn nhé. Làm xong các bạn ấn OKE (số 5) để qua bước tiếp theo.
winbox-cai-dat-scrip.jpg

Bước 2: Để tiến hành lên lịch chạy sao lưu cấu hình tự động các bạn cần vào tiếp System (1) => Scheduler (2) => add (3)
Tiếp theo bảng Schedule hiện ra các bạn cần làm các việc sau:
Name: Đặt là gì tùy bạn
Start Date: mặc định nó chọn giúp rồi
Start Time: Bắt đầu lúc mấy giờ.
Interval: Bao nhiêu lâu chạy lại một lần, như mình đang để 12 tiếng nó sẽ chạy backup một lần.
Phần số 5: các bạn copy đoạn script này vào => /system script run BackupAndUpdate;
Phần số 6: ấn oke thôi chứ có gì mà khó.

Vậy là xong phần cấu hình tự động backup và update phiên bản routeros mới khi có rồi á. Chúc bạn thành công.
P/s: bản backup sẽ được gửi về hòm thư nhé mọi người. Ảnh minh họa ở dưới.

winbox-cai-dat-scrip-1.jpg
winbox-cai-dat-scrip-2-1024x675.jpg

C2/ Script tự động đổi DNS và thông báo qua telegram

Nếu bạn đang dùng DNS cá nhân, bạn gắn DNS cá nhân này lên router mạng ở nhà và không may DNS cá nhân này bị sự cố không truy cập được thì mạng ở nhà bạn sẽ tèo à? Vậy làm cách nào bây giờ?
Đơn giản thôi, đoạn script dưới đây sẽ giúp bạn tự động kiểm tra DNS cá nhân của bạn nếu nó không may gặp sự cố thì nó sẽ đổi DNS cá nhân của bạn qua DNS của google và khi DNS cá nhân của bạn truy cập lại được thì nó sẽ lại đổi DNS google về DNS cá nhân của bạn. ĐƠn giản không :D.

Cuộc sống thật là đơn giản nhỉ?
Để tiến hành báo tự động qua telegram thì bạn cần tạo bot telegram, cần thêm một group chát nữa (group chát này chỉ có bạn với con bot bạn vừa tạo thôi). Cái này các bạn google thôi đơn giản nhỉ,

Bước 1: Các bạn vào system (1) => Scheduler (2) => add (3)
Sau khi bảng Schedule hiện ra, các bạn đặt các thông số sau:
Name: Đặt là gì tùy các bạn.
Start Date: hệ thống tùy chọn cho bạn rồi
Start Time: hệ thống tùy chọn hoặc tùy các bạn chọn
Interval: mấy giây kiểm tra một lần? Như mình đang để là 1 phút kiểm tra một lần
Số 5: Đoạn script để kiểm tra, các bạn copy ở dưới nhé
Số 6: Ấn oke để bắt đầu thôi

:local telegramBotKey "YOUR_BOT_ID"
:local chatID "YOUR_CHAT_CHANNEL_ID"

:local currentDNS [/ip dns get server]
:local piholeDNS "YOUR_DNS"
:local backupDNS "8.8.8.8,1.1.1.1"
:local testDomain "www.google.com"

:if ($currentDNS = $piholeDNS) do={
:do {
:resolve $testDomain server $piholeDNS
} on-error={
/ip dns set servers=$backupDNS
/ip dhcp-server network set [find] dns-server=$backupDNS;
/tool fetch "https://api.telegram.org/bot$telegramBotKey/sendmessage\?chat_id=$chatID&text=Pi-Hole not working! Changed DNS from $currentDNS to $backupDNS." keep-result=no
}
} else={
:do {
:resolve $testDomain server $piholeDNS
/ip dns set servers=$piholeDNS
/ip dhcp-server network set [find] dns-server=$piholeDNS;
/tool fetch "https://api.telegram.org/bot$telegramBotKey/sendmessage\?chat_id=$chatID&text=Pi-Hole is working again. Changed DNS from $currentDNS to $piholeDNS.&disable_web_page_preview=true" keep-result=no
} on-error={}
}
winbox-cai-dat-scrip-3.jpg

Thành quả:
Chúc các bạn thành công.

F0W8A22.jpg



C3/ Tự động chặn internet theo thời gian nhất định.

Câu hỏi này thì mình nhận được từ bạn “Tài”. Nói chung là có nhiều cách để chặn truy cập internet trong 1 khoảng thời gian nhất định. Dưới đây là một đoạn mã trong số rất nhiều cách làm.
Nguyên lý của đoạn mã bên dưới đó là tới thời gian bạn chọn thì hệ thống tự động “vô hiệu hóa cổng eth1”, ở đây mình ví dụ cổng “eth1” đang là cổng quay số PPPOE nhé. Còn nếu các bạn đang quay số PPPOE ở cổng 2, 3, 4 thì các bạn đổi lại cho đúng nhé.

Để gõ lệnh các bạn vào giao diện winbox => new terminal sau đó copy từ /system scheduler nhé.

// Disable ether1
/system scheduler
add comment=”DisableInternet” disabled=no interval=1d name:Disable Internet on-event=”/interface wireless disable ether1-gateway” policy=read,write,test start-date=Mar/08/2020 start-time=03:00:00

// Dòng lệnh trên có nghĩa là cứ vào 3h sáng hàng ngày, hệ thống sẽ tự động “disable / vô hiệu hóa cổng ether1”.

// Enable ether1
/system scheduler
add comment=”Enable Internet” disabled=no interval=1d name=Enable Internet on-event=”/interface wireless enable ether1-gateway” policy=read,write,test start-date=Mar/08/2020 start-time=06:00:00

//Dòng lệnh trên có nghĩa là cứ vào 6h sáng hàng ngày, hệ thống sẽ kích hoạt lại cổng ether1, cổng ether1 đang là cổng quay số PPPOE nhé các bạn.
 
Last edited:

Darias

Senior Member
Lại thêm bài viết có tâm khác -.-
Ham hố quá!!!
Mà cấp giấy phép 4 với cấp giấy phép 6 thì cái nào nhiều chức năng hơn vậy các bạn?
 
Last edited:

loiutd

Senior Member
Vẫn còn bị lấn cấn vụ đồng bộ thời gian. Đang nghi do nó bị sai mà thỉnh thoảng bị quay pppoe toàn fail (mất tầm nửa tiếng kết nối lại). Mình vô SNTP điền server ntp google, rồi của vn.pool.ntp.org mà nó vẫn ko chạy đồng bộ. Đã add Firewall rule thông cổng 123 luôn. Đã thử cài thêm package ntp từ trang chủ luôn. Vẫn ko chạy đc. Phải chỉnh tay :v
Đặt trường hợp mất điện tầm 5p là tạch
 

Forever963

Senior Member
Vẫn còn bị lấn cấn vụ đồng bộ thời gian. Đang nghi do nó bị sai mà thỉnh thoảng bị quay pppoe toàn fail (mất tầm nửa tiếng kết nối lại). Mình vô SNTP điền server ntp google, rồi của vn.pool.ntp.org mà nó vẫn ko chạy đồng bộ. Đã add Firewall rule thông cổng 123 luôn. Đã thử cài thêm package ntp từ trang chủ luôn. Vẫn ko chạy đc. Phải chỉnh tay :v
Đặt trường hợp mất điện tầm 5p là tạch

Vào system -> packages -> update. Sau đó IP-> dns 8.8.8.8/1.1.1.1

Lại thêm bài viết có tâm khác -.-
Ham hố quá!!!
Mà cấp giấy phép 4 với cấp giấy phép 6 thì cái nào nhiều chức năng hơn vậy các bạn?

LV4 có giới hạn quay PPPOE và vài cái kết nối VPN. LV6 thì không.
 

tmk1207

Senior Member
con này hình như đâu có MU-MIMO

Con này ko phải sinh ra để phát wifi, nên đừng đòi hỏi nó phải như một AP chuyên dụng, mặc dù có thể nó còn hơn cả bọn chuyên dụng ở vài cái đấy.

Còn bản thân con chip nó đang sở hữu có chế độ Mu-Mimo rồi đó, còn hãng nó có viết fw cho để kích hoạt hay không là chuyện khác. Chạy riêng router thôi nóng đã như đốt lò, giờ thêm wifi với mumo gì đó chắc cháy nhà.
 

Forever963

Senior Member
Con này ko phải sinh ra để phát wifi, nên đừng đòi hỏi nó phải như một AP chuyên dụng, mặc dù có thể nó còn hơn cả bọn chuyên dụng ở vài cái đấy.

Còn bản thân con chip nó đang sở hữu có chế độ Mu-Mimo rồi đó, còn hãng nó có viết fw cho để kích hoạt hay không là chuyện khác. Chạy riêng router thôi nóng đã như đốt lò, giờ thêm wifi với mumo gì đó chắc cháy nhà.

Làm combo Ac2+ redmi ac2100 nào :D
 

nguoidingoaipho

Senior Member
Newifi ăn đứt. Mà xét tổng thể và độ ổn định nó ăn cám!
Chỉ phát wifi cho tầm 50 máy thì có bền bỉ k bác? K quay pppoe, chỉ nhận ip từ router đi vào cổng wan và cấp lại dhcp cho các máy con nối vào thôi
 

Q.C 3.0

Junior Member
Con này ko phải sinh ra để phát wifi, nên đừng đòi hỏi nó phải như một AP chuyên dụng, mặc dù có thể nó còn hơn cả bọn chuyên dụng ở vài cái đấy.

Còn bản thân con chip nó đang sở hữu có chế độ Mu-Mimo rồi đó, còn hãng nó có viết fw cho để kích hoạt hay không là chuyện khác. Chạy riêng router thôi nóng đã như đốt lò, giờ thêm wifi với mumo gì đó chắc cháy nhà.
Lan man quá bác, đã hỗ trợ chuẩn ac wave 2 là phải hỗ trợ mu mimo rồi không cần nói nhiều :byebye:
 

tmk1207

Senior Member
Lan man quá bác, đã hỗ trợ chuẩn ac wave 2 là phải hỗ trợ mu mimo rồi không cần nói nhiều :byebye:

Cùng là 4 bánh, ông mua con chuyên để đi đường núi lại đòi nó chạy nhanh như đi đồng bằng thì cũng chịu.
 
Top