thảo luận Cộng đồng người dùng MikroTik Router

Bác chỉ em vụ tìm IP game theo domain được không
bác dựng con pihole hay adguardhome, v7 bác chạy container luôn cho tiện, rồi trỏ dns trong lan về nó để nó bắt domain phân giải ra ip thôi. trên mik thì bác chỉ cần biết domain game là đủ rồi. trong ip/firewall/raw bác lọc domain game đã biết để mik bắt ip game , add vào 1 cái list. xong rồi route cái list đó theo wan nào mình muốn thôi. bên mik nó tự động được cái vụ lấy ip từ domain add vào list, chứ bên pfsense e toàn phải copy tay.
game.PNG

cái này là ví dụ game thằng cháu đang chơi
ps còn cách nữa là cho mik làm dns resolve luôn
 
e trước có config loadbalance theo y như mik vn thì ở nhà dùng app hay web vào các bank bình thường hết, kể cả web của thuế cá nhân. Nhưng e thấy vẫn có người bị lỗi này. Còn ip bank thì theo e dựng cái dns local ( e xài adguardhome), rồi bắt domain của bank xong , raw cái domain vào address list, cuối cùng là route cái list đó đi ra 1 wan cố định. e trước xài mik cũng bắt domain game của mấy đứa cháu trong nhà bằng cách này rồi route qua 4g, bên pf thì cực hơn phải lấy ip bằng tay.
Em xin link hướng dẫn của mkvn bác ơi
 
Em xin link hướng dẫn của mkvn bác ơi
Trên Mikrotik thì như sau nhé thím:
/ip firewall address-list
add address=192.168.1.0/24 list=LOCAL-IP
/ip firewall raw
add action=add-dst-to-address-list address-list=ten list ip muon lay \
address-list-timeout=1w chain=prerouting content=domain de loc ip \
dst-address-list=!LOCAL-IP src-address-list=LOCAL-IP
 
Các bác cho hỏi chút ạ.
Mình có tạo VPN L2TP để kết nối mạng từ nhà đến công ty.
Sau khi đã kết nối thành công nhưng khi truy cập mạng nội bộ ở máy tính công ty thì nó lại hiện ra cái này bắt nhập pass của user L2TP. Mình nhập xong cũng ko truy cập đc. Trên Mik mình đang loadbancing 2 đường, đã chọn Proxy-Arp ở mục Bridge và ở mục Mangle đã làm prerouting cho L2TP và kéo lên đầu tiên nhưng vẫn ko đc,
Mong các bác giúp đỡ với
Mình có làm cả PPTP cũng bị hiện tượng như trên.
Đã làm theo video này mà vẫn ko truy cập đc
 
Bác chỉ em vụ tìm IP game theo domain được không
Ví dụ như mình lấy domain game Roblox để chặn truy cập của thằng cu nhà bằng scripts đơn giản sau, thím muốn lấy game nào thì thay thế từ khóa cần thiết vào.
Code:
while (1) do={
foreach dnscache in=[/ip dns cache find] do={
local dnscacheVal [/ip dns cache get $dnscache]
local dnscacheName ($dnscacheVal->"name")
local dnscacheData ($dnscacheVal->"data")
local dnscacheType ($dnscacheVal->"type")

# List IP IP Roblox
if ( $dnscacheName ~"(roblox)" ) do={
  if ( $dnscacheType="A" ) do={
     do {/ip/firewall/address-list/add list="IP Roblox" address=$dnscacheData comment="IP Roblox"} on-error={ }
  }
  if ( $dnscacheType="CNAME" ) do={
     do {/ip/firewall/address-list/add list="IP Roblox" address=$dnscacheName comment="IP Roblox"} on-error={ }
  }
}
}
delay 2s
}
IP_ROBLOX.jpg
 
Ví dụ như mình lấy domain game Roblox để chặn truy cập của thằng cu nhà bằng scripts đơn giản sau, thím muốn lấy game nào thì thay thế từ khóa cần thiết vào.
Code:
while (1) do={
foreach dnscache in=[/ip dns cache find] do={
local dnscacheVal [/ip dns cache get $dnscache]
local dnscacheName ($dnscacheVal->"name")
local dnscacheData ($dnscacheVal->"data")
local dnscacheType ($dnscacheVal->"type")

# List IP IP Roblox
if ( $dnscacheName ~"(roblox)" ) do={
  if ( $dnscacheType="A" ) do={
     do {/ip/firewall/address-list/add list="IP Roblox" address=$dnscacheData comment="IP Roblox"} on-error={ }
  }
  if ( $dnscacheType="CNAME" ) do={
     do {/ip/firewall/address-list/add list="IP Roblox" address=$dnscacheName comment="IP Roblox"} on-error={ }
  }
}
}
delay 2s
}
thím chặn nên dễ làm hơn mình là route, vd domain này(
hydra.easyanticheat.net) không có chữ gì dính đến game battle field, nhưng khi chơi thì sẽ load domain này luôn.
ps mình không đủ giỏi như thím nên phải làm cách dựng dns local
 
Last edited:
thím chặn nên dễ làm hơn mình là route, vd domain này(
hydra.easyanticheat.net) không có chữ gì dính đến game battle field, nhưng khi chơi thì sẽ load domain này luôn.
ps mình không đủ giỏi như thím nên phải làm cách dựng dns local
chặn và route cũng gần nhau mà thím, cái bộ lọc thím cho đủ từ khóa vào là nó lấy IP, domain đủ cả, lại nhanh nhẹ nữa.
 
chặn và route cũng gần nhau mà thím, cái bộ lọc thím cho đủ từ khóa vào là nó lấy IP, domain đủ cả, lại nhanh nhẹ nữa.
chặn thì thím chỉ cần chặn 1 domain là có thể không chơi được game, nhưng route mà thiếu domain thì bị rớt gói ping cao. Ý mình là vậy đó thím
 
chặn thì thím chỉ cần chặn 1 domain là có thể không chơi được game, nhưng route mà thiếu domain thì bị rớt gói ping cao. Ý mình là vậy đó thím
Drop và routing giống nhau như bạn @maihuong1990 nói mà bạn, chẳng qua thay vì định tuyến nó qua máy chủ ảo bên ngoài thì RouterOS định tuyến nó đến địa chỉ 127.0.0.1 là drop tên miền cần chặn. Còn việc đủ thiếu tên miền là do bạn tự lọc ra, muốn ping thấp thì phải tự chọn máy chủ ảo thủ công hoặc dùng các dịch vụ VPN chuyên định tuyến game.
 
Drop và routing giống nhau như bạn @maihuong1990 nói mà bạn, chẳng qua thay vì định tuyến nó qua máy chủ ảo bên ngoài thì RouterOS định tuyến nó đến địa chỉ 127.0.0.1 là drop tên miền cần chặn. Còn việc đủ thiếu tên miền là do bạn tự lọc ra, muốn ping thấp thì phải tự chọn máy chủ ảo thủ công hoặc dùng các dịch vụ VPN chuyên định tuyến game.
Drop: không cần phải biết hết tên miền game
Route: cần phải biết hết tên miền game
Drop: không cần quan tâm đến đường ra net tốt hay xấu
Route: cần quan tâm đến đường ra net tốt hay xấu
Cho nên theo mình drop dễ hơn route là vậy
 
Drop: không cần phải biết hết tên miền game
Route: cần phải biết hết tên miền game
Drop: không cần quan tâm đến đường ra net tốt hay xấu
Route: cần quan tâm đến đường ra net tốt hay xấu
Cho nên theo mình drop dễ hơn route là vậy
Mình cũng vừa drop vừa route đây thím. Mấy dịch vụ ít domain, ip thì dễ. Chứ như youtube, tiktok drop hay route nó cũng vã lắm.
 
Mình cũng vừa drop vừa route đây thím. Mấy dịch vụ ít domain, ip thì dễ. Chứ như youtube, tiktok drop hay route nó cũng vã lắm.
cái script thím chạy ăn cpu ít hơn là lọc raw không thím? mình lọc raw cho 2 game clashofclan vs battlefield cũng cỡ 4x rule. Mình lọc chính xác tới từng tên miền game luôn chứ không xài từ khóa
 
mấy thím cho lọc raw mấy hôm là tắt hay cho nó chạy hoài thế.
cái script thím chạy ăn cpu ít hơn là lọc raw không thím? mình lọc raw cho 2 game clashofclan vs battlefield cũng cỡ 4x rule. Mình lọc chính xác tới từng tên miền game luôn chứ không xài từ khóa
 
cái script thím chạy ăn cpu ít hơn là lọc raw không thím? mình lọc raw cho 2 game clashofclan vs battlefield cũng cỡ 4x rule. Mình lọc chính xác tới từng tên miền game luôn chứ không xài từ khóa
Script thì chạy ăn ít cpu lắm.
Script chạy liên tục, route hay drop nhanh, mượt luôn. Mình lấy ip của youtube, tikok, zalo, facebook...mà cpu ko xài là mấy
 
mấy thím cho lọc raw mấy hôm là tắt hay cho nó chạy hoài thế.
router mà mạnh thì để chạy luôn thím, còn yếu yếu thì chạy khoảng 1 tuần rồi tắt, thỉnh thoảng mở lại. Chứ lọc raw như mình 4x raw rule, mik 450gx4 line vietel 150Mbps, bật lọc raw lên speedtest rớt còn 8xMbps
 
router mà mạnh thì để chạy luôn thím, còn yếu yếu thì chạy khoảng 1 tuần rồi tắt, thỉnh thoảng mở lại. Chứ lọc raw như mình 4x raw rule, mik 450gx4 line vietel 150Mbps, bật lọc raw lên speedtest rớt còn 8xMbps
Trk e cũng hay dùng raw lọc, Hiển thị cpu lúc nào cũng 1%,ngon lắm mà speedtest k đạt.Sau này mới đc chỉ tắt đi thì speedtest ngon lại.V là cái hiển thị cpu của Mik nó ngáo à.
 
Trk e cũng hay dùng raw lọc, Hiển thị cpu lúc nào cũng 1%,ngon lắm mà speedtest k đạt.Sau này mới đc chỉ tắt đi thì speedtest ngon lại.V là cái hiển thị cpu của Mik nó ngáo à.
Mình thấy mik hiển thị cpu đúng mà, như mình speedtest thì cpu lên 8x % khi chạy bình thường thì cpu cũng nhảy 2x 3x % chứ ít khi nào mà ở 1% lắm
 
Back
Top