thắc mắc Restart laptop bị bị ẩn HDD lắp trên caddy bay

Fountain Head

Junior Member
Chào mọi người, mình có 1 vấn đề cần trợ giúp.

Mình mới lắp SSD cho laptop. Và để tận dụng cái HDD cũ, mình mua caddy bay để lắp vào vị trí của ổ DVD.
Ban đầu khởi động lại, các phân vùng vẫn hiện đầy đủ cả SSD và HDD.
Tuy nhiên sau khi Restart thì các phân vùng thuoojv HDD liền biến mất.
Mình vào BIOS kiểm tra thì vẫn thấy có HDD.
IMG_20210707_1201222.jpg

Mình dùng USB boot ở dạng UEFI để vào mini Win kiểm tra thì không thấy xuất hiện HDD, nhưng nếu boot ở dạng Legacy thì lại xuất hiện.
Mình đã thử format tất cả 2 ổ HDD và SSD để cài lại Windows. Nếu cài Windows lên HDD thì tất cả các phân cùng đều hiện. Nhưng nếu cài trên SSD thì chỉ hiện SSD.
Một điều lạ nữa là nếu đang chạy windows trên SSD, chỉ Shutdown và khởi động lại thì các phân vùng không biến mất. Chỉ khi nào chọn Restart thay vì shutdown thì mới bị ẩn mất các phân vùng HDD.

Có bạn nào bị tương tự hoặc có kinh nghiệm xử lý vụ này làm ơn chỉ giúp mình!
Cảm ơn mọi người đã đọc!
 

Avataro

Junior Member
Dùng phần mềm "EaseUS Partition Master Setup'' để format usb, hdd, ssd nhé (khuyên dùng). Hoặc dùng MediaCreationTool phát hành tháng 8/2015 (bắt buộc) để tạo usb boot, rồi format ổ cài win. Mình không dám chắc 100% sẽ fix được lỗi bạn đang gặp (vì mình chưa gặp lỗi tương tự), cách này mình hay dùng fix win khóa đủ thứ rồi lưu trong phân vùng ẩn - phân vùng này còn tồn tại là lỗi còn tồn tại theo.
Không up được file trực tiếp lên voz nên bạn chịu khó Google. Lót dép đợi thêm cách fix chính xác hơn của thím khác.
 

Fountain Head

Junior Member
Dùng phần mềm "EaseUS Partition Master Setup'' để format usb, hdd, ssd nhé (khuyên dùng). Hoặc dùng MediaCreationTool phát hành tháng 8/2015 (bắt buộc) để tạo usb boot, rồi format ổ cài win. Mình không dám chắc 100% sẽ fix được lỗi bạn đang gặp (vì mình chưa gặp lỗi tương tự), cách này mình hay dùng fix win khóa đủ thứ rồi lưu trong phân vùng ẩn - phân vùng này còn tồn tại là lỗi còn tồn tại theo.
Không up được file trực tiếp lên voz nên bạn chịu khó Google. Lót dép đợi thêm cách fix chính xác hơn của thím khác.
Cảm ơn thím! Mình đã dùng Magic Partion format toàn bộ 2 ổ SSD và HDD (bao gồm tất cả các phân vùng ẩn) Định dạng lại letter cho từng phân cùng mà cũng không khắc phục được.
Loại trừ nguyên nhân ở caddy bay vì mình đã thay 2 caddy bay khác cũng không được.
Hóng cao nhân!
 

Avataro

Junior Member
Cảm ơn thím! Mình đã dùng Magic Partion format toàn bộ 2 ổ SSD và HDD (bao gồm tất cả các phân vùng ẩn) Định dạng lại letter cho từng phân cùng mà cũng không khắc phục được.
Loại trừ nguyên nhân ở caddy bay vì mình đã thay 2 caddy bay khác cũng không được.
Hóng cao nhân!
Nếu có thời giam thím cứ dùng thử app em nhắc tới 1 lần xem sao nhé. Cảm ơn thím. (thím có gắn ổ cứng qua máy khác để hạ slave chưa)
 

Fountain Head

Junior Member
Nếu có thời giam thím cứ dùng thử app em nhắc tới 1 lần xem sao nhé. Cảm ơn thím. (thím có gắn ổ cứng qua máy khác để hạ slave chưa)
Thank thím! Mình đã thử mang HDD gắn qua máy khác vẫn nhận. Còn hạ slave là gì thím?
 

Avataro

Junior Member
Thank thím! Mình đã thử mang HDD gắn qua máy khác vẫn nhận. Còn hạ slave là gì thím?
Mình quen miệng dùng từ ngữ cũ. Nghĩa là thím cài app trên máy khác, rồi dùng máy đó (master) format ssd, hdd, usb tháo từ máy cần format (slave). Không format trực tiếp tại máy đang lỗi đó thím.
 

PsiStorm

Senior Member
Ông thớt laptop Asus à, boot menu giống y hệt máy mình.
Chưa gặp trường hợp của thớt bao giờ, nhưng cũng xin đưa vài ý tưởng cho thớt thử chơi:
  • Trước tiên tắt hết Secure boot, Raid mode trong bios. Dạo này tôi toàn cài máy HP, Dell, lâu ko động vào Asus ko biết nó có mấy option kiểu vậy ko. Update driver mới nhất trên trang chủ nữa, đặc biệt là mấy driver I/O
  • Thử SSD chuẩn GPT, HDD (caddy bay) chuẩn GPT, trên bios cài boot chuẩn UEFI
  • Thử SSD chuẩn MBR, HDD (caddy bay) chuẩn MBR, trên bios cài boot chuẩn Legacy
  • Thử mấy cái trên mà ko được thì thử thay ổ đi, mượn 1 con SSD khác lắp vào chỗ con HDD trên caddy bay
  • Ko được nữa thì đập máy
    RPOxGRd.png
 

Fountain Head

Junior Member
Ông thớt laptop Asus à, boot menu giống y hệt máy mình.
Chưa gặp trường hợp của thớt bao giờ, nhưng cũng xin đưa vài ý tưởng cho thớt thử chơi:
  • Trước tiên tắt hết Secure boot, Raid mode trong bios. Dạo này tôi toàn cài máy HP, Dell, lâu ko động vào Asus ko biết nó có mấy option kiểu vậy ko. Update driver mới nhất trên trang chủ nữa, đặc biệt là mấy driver I/O
  • Thử SSD chuẩn GPT, HDD (caddy bay) chuẩn GPT, trên bios cài boot chuẩn UEFI
  • Thử SSD chuẩn MBR, HDD (caddy bay) chuẩn MBR, trên bios cài boot chuẩn Legacy
  • Thử mấy cái trên mà ko được thì thử thay ổ đi, mượn 1 con SSD khác lắp vào chỗ con HDD trên caddy bay
  • Ko được nữa thì đập máy
    RPOxGRd.png
Mấy cái thím bảo mình làm cả rồi. Có mỗi cái chưa đập máy với không biết tắt Secure Boot của laptop Asus như nào. Của Dell với HP thì mình biết, riêng thằng Asus này nó loằng ngoằng thật. Trong Secure Boot không thấy có tùy chọn tắt nào luôn.
Thank thím!
 

lixlix225

Đã tốn tiền
Trên caddy bay có công tắc gạt bên hông, bạn thử gạt nó qua coi sao. Một số loại laptop kén phải dùng băng keo che bớt chân pin trên caddy bay nó mới nhận. Bạn tìm hiểu thử trên mạng xem có người nào dùng laptop model giống của bạn có gặp tình trạng này chưa để biết cách giải quyết.
 

Fountain Head

Junior Member
Trên caddy bay có công tắc gạt bên hông, bạn thử gạt nó qua coi sao. Một số loại laptop kén phải dùng băng keo che bớt chân pin trên caddy bay nó mới nhận. Bạn tìm hiểu thử trên mạng xem có người nào dùng laptop model giống của bạn có gặp tình trạng này chưa để biết cách giải quyết.
Cảm ơn thím! Mình thử tìm hiểu.
Có phải bị tình trạng 1 lần thấy / 1 lần không khi restart?! :sweat:
Của mình khi nó còn đang hiện HDD thì nếu shutdown bật lại thì không biến mất.
Nhưng chỉ cần Restart là nó ẩn luôn.
Muốn nó hiện lại, phải boot vào WinPE sau đó thoát ra bật lại rất phiền phức.
Cảm ơn thím!
 
Top