thảo luận Tất tần tật về Cisco

trakimanhminh

Đã tốn tiền
Chào các thím,

Chẳng qua là dịch rảnh rỗi quá, nên mình lập topic này, chia sẻ về cấu hình các thiết bị Cisco: Router, Switch, Controller, AP.

** Video hướng dẫn chi tiết **

1. Cấu hình quay số pppoe:


2. Cấu hình quay số pppoe Viettel tag VLAN 35:


3. Cách reset router Cisco:


4. Cách reset router khi vướng "PASSWORD RECOVERY FUNCTIONALITY IS DISABLED" :


5.
Hướng dẫn khôi phục và copy IOS vào flash trên Cisco router trong chế độ ROMMON bằng TFTP:


---> Cách cấu hình quay số pppoe cho Cisco Router <---

-> Cổng g0/0 kết nối với máy tính.
-> Cổng g0/1 kết nối modem VNPT
-> VD: Tên đường truyền là aaaa, password là bbbb
-> Cấu hình Router như sau:

router> en
Nhập password nếu có
router# conf t

* Bắt đầu cấu hình port kết nối với Modem VNPT *

router(config)# interface g0/1
router(config-if)# description $VNPT$
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 1
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

* Bắt đầu quay số pppoe *

router(config)# int dialer 1
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 1
router(config-if)# dialer-group 1
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username aaaa password 0 bbbb
router(config-if)# ppp chap hostname aaaa
router(config-if)# ppp chap password bbbb
router(config-if)# exit

* Bắt đầu cấu hình port kết nối LAN *

router(config)#int g0/0
router(config-if)# ip add 192.168.1.1 255.255.255.0
router(config-if)# no shut
router(config-if)# ip nat inside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# ip virtual-reassembly
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

* Cấu hình định tuyến, để các IP bên ngoài có thể đi vào router thông qua dialer 1 *

router(config)# ip route 0.0.0.0 0.0.0.0 dialer 1

* Tạo danh sách IP bên trong LAN được phép kết nối ra internet *

router(config)# access-list 1 permit 192.168.1.0 0.0.0.255

* Cấu hình NAT theo access-list đã cấu hình phía trên *

router(config)# ip nat inside source list 1 interface dialer 1 overload

* Tạo pool DHCP để cấp IP cho các máy bên trong mạng LAN *

router(config)# service dhcp
router(config)# ip dhcp pool 1
router(config-if)# network 192.168.1.0 255.255.255.0
router(config-if)# default-router 192.168.1.1
router(config-if)# dns-server 8.8.8.8
router(config-if)# exit

* Tạo dải IP loại trừ để phòng trường hợp cần set IP tĩnh *

router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.20
router(config)#exit

* Lưu toàn bộ cấu hình *

router# wr

* Lưu ý *
1. Đối với mạng VNPT, cần tắt modem nhà mạng tầm 20-30s, sau đó mở lại.
2. Đối với mạng FPT, cần gọi lên tổng đài để xác thực MAC-Address
3. Đối với mạng Viettel, lúc trước cần phải tag VLAN 35, nhưng sau này họ đã bỏ tag, nên trước khi cấu hình, cần phải hỏi rõ để cấu hình cho chính xác.

---> Extra: Cấu hình quay số pppoe đối với đường FTTH Viettel cần tag VLAN 35 <---

Sơ đồ

F0/1: Kết nối với VIETTEL
F0/0: Kết nối với SWITCH hoặc LAPTOP, PC
Bạn cấu hình như sau:

---> Cấu hình port f0/0 <---

router# conf t
router(config)# int f0/0
router(config-if)# description $LOCAL_LAN$
router(config-if)# ip add 192.168.10.1 255.255.255.0
router(config-if)# no shut
router(config-if)# ip nat inside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# ip virtual-reassembly in
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

---> Cấu hình port f0/1 và tag vlan 35 <---

router(config)# interface f0/1
router(config-if)# no shutdown
router(config-if)# exit
router(config-if)# interface f0/1.35
router(config-if)# description $VIETTEL_1$
router(config-if)# encapsulation dot1q 35
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 1
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# exit

---> Tiến hành quay số pppoe <---

router(config)# int dialer 1
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 1
router(config-if)# dialer-group 1
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username aaaa password 0 bbbb
router(config-if)# ppp chap hostname aaaa
router(config-if)# ppp chap password bbbb
router(config-if)# exit

---> Tiến hành route, NAT, cấu hình access-list, pool DHCP <---

router(config)# ip route 0.0.0.0 0.0.0.0 dialer 1
router(config)# access-list 1 permit 192.168.10.0 0.0.0.255
router(config)# ip nat inside source list 1 interface dialer 1 overload
router(config)# service dhcp
router(config)# ip dhcp pool 1
router(config-if)# network 192.168.10.0 255.255.255.0
router(config-if)# default-router 192.168.10.1
router(config-if)# dns-server 8.8.8.8
router(config-if)# exit

---> Tạo dải IP loại trừ và lưu cấu hình <---

router(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.20
router(config)#exit
router# wr

---> Cách chia VLAN và Sub Interface trên Cisco Router và Switch <---

* Chia VLAN trên Switch *
switch> en
Nhập password nếu có
switch# conf t
switch(config)# vlan 10 ---> tạo vlan 10
switch(config-vlan)# name TIGERNET ---> đặt tên cho vlan
switch(config-vlan)# exit
switch(config)# int vlan 10
switch(config-if)# ip add 192.168.10.1 255.255.255.0 ---> Gán IP cho vlan 10
switch(config-if)# end
switch# write

* Chia VLAN trên Router *
router> en
Nhập password nếu có
router# conf t
router(config)# interface g0/0.10 ---> Tạo sub - interface trên router
router(config-if)# encapsulation dot1q 10 ---> Gán và tạo vlan 10
router(config-if)# ip add 192.168.10.1 255.255.255.0 ---> Gán địa chỉ IP
router(config-if)# no shut ---> Do mặc định cổng WAN luôn ở chế độ shut, nên phải no shut để port luôn ở chế độ on.
router# write

* Chia VLAN trên router 8xx, hoặc router có gắn thêm card HWIC-4ESW, EHWIC-4ESG, NIM-ES2-4,... *

router> en
Nhập password nếu có
router# conf t
router(config)# vlan 10 ---> tạo vlan 10
router(config-vlan)# name TIGERNET ---> đặt tên cho vlan
router(config-vlan)# exit
router(config)# int vlan 10
router(config-if)# ip add 192.168.10.1 255.255.255.0 ---> Gán IP cho vlan 10
router(config-if)# end
router# write

Lưu ý
1. Trên router series 8xx hoặc router có gắn thêm card mở rộng, VLAN có thêm chức năng NAT, còn đối với các switch thì VLAN không có chức năng này.
2. Địa chỉ IP VLAN trên router không được phép trùng với địa chỉ IP của các cổng mạng.
VD: IP port G0/0 là 192.168.1.1 thì VLAN 1 không thể đặt IP là 192.168.1.10, lúc này router sẽ báo lỗi.

---> Cách telnet hoặc ssh vào các Router Cisco <---

* Mục đích: Quản trị từ xa bằng Telnet hoặc SSH *

* Cấu hình Telnet *

router> en
Nhập password nếu có
router# conf t
router(config)# enable secret Tigernet
router(config-line)# line vty 0 4
router(config-line)# transport input telnet
router(config-line)# password Tigernet
router(config-line)# login
router(config-line)# end
router# wr

* Đôi khi, một số nhà mạng chặn port mặc định 23, do đó chúng ta thay đổi port mặc định thành 3223 như sau *

router(config)# ip nat inside source static tcp 192.168.1.1 23 interface Dialer1 3223
Trong đó:
---> 192.168.1.1 là IP của default-gateway

Sau khi cấu hình xong, chúng ta đã có thể telnet vào router từ xa, với địa chỉ IP pulic (Có thể vào ping.eu để kiểm tra), bằng port 23 (Mặc định) hoặc port 3223 (Sau khi thay đổi)

* Cấu hình SSH*

router> en
Nhập username hoặc password nếu có
router# conf t
router(config)# hostname TIGERNET
TIGERNET(config)# enable password Tigernet
TIGERNET(config)# ip domain name tigernet.com.vn
TIGERNET(config)# ip ssh version 2
TIGERNET(config)# crypto key generate rsa

The name for the keys will be: tigernet.com.vn
Choose the size of the key modulus in the range of 360 to 4096 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 512
% Generating 768 bit RSA keys, keys will be non-exportable...
[OK] (elapsed time was 2 seconds)

TIGERNET(config)# username Tigernet privilege 15 password Tigernet
TIGERNET(config)# line vty 0 4
TIGERNET(config-line)# login local
TIGERNET(config-line)# transport input ssh
TIGERNET(config-line)# exec-timeout 0 0 ---> Để không bị timeout khi không tác động đến phiên ssh
TIGERNET(config-line)#end
TIGERNET#wr

Sau khi cấu hình xong, chúng ta đã có thể SSH vào router từ xa, với địa chỉ IP pulic (Có thể vào ping.eu để kiểm tra), bằng port 22 (Mặc định).

* Lưu ý *
---> SSH luôn được đánh giá cao hơn Telnet về mặt bảo mật
---> Có thể kết hợp với access-list để cấu hình thêm các lựa chọn (Chỉ cho phép 1 IP hoặc dải IP nhất định nào đó telnet hoặc ssh đến,...)

---> Cách cấu hình cân bằng tải, cộng gộp băng thông trên switch bằng EtherChannel <---

Mục đích

1. Cân bằng tải giữa Router với Switch, Switch với Switch. Đặc biệt hữu hiệu khi chạy chế độ stack giữa 2 switch với nhau, khi 1 switch gặp sự cố, đường link không bị down.
2. Gộp 2 hoặc nhiều ports (Tối đa 8 ports) thành 1 port để tăng băng thông. VD: Gộp 8port 1Gbs thành 1 port 10Gbs.

Tiến hành cấu hình như sau

Switch 1:

switch1> en
Nhập password nếu có
switch1# conf t
switch1(config)# port-channel load-balance src-dst-mac
switch1(config)# interface Port-channel2
switch1(config-if)# description LINK TO SWITCH 2
switch1(config-if)# switchport trunk allowed vlan 1,7,10 ---> Cho phép các vlan được phép đi qua etherchannel này
switch1(config-if)# switchport mode trunk
switch1(config-if)# exit
switch1(config)# interface range GigabitEthernet1/0/1-2 ---> Gộp 2 port
switch1(config-if)# shut
switch1(config-if)# description Portchannel 2 Switch 1
switch1(config-if)# switchport trunk allowed vlan 1,7,10
switch1(config-if)# switchport mode trunk
switch1(config-if)# channel-protocol lacp ---> Phương thức này để cho phép sử dụng kết nối giữa switch Cisco và non-Cisco
switch1(config-if)# channel-group 2 mode active
switch1(config-if)# no shut
switch1(config-if)# end
switch1# wr

Trên switch 2:

switch2> en
Nhập password nếu có
switch2#conf t
switch2(config)# port-channel load-balance src-dst-mac
switch2(config)# interface Port-channel2
switch2(config-if)# description LINK TO SWITCH 1
switch2(config-if)# switchport trunk allowed vlan 1,7,10
switch2(config-if)# switchport mode trunk
switch2(config)# exit
switch2(config-if)# interface range GigabitEthernet1/0/1-2
switch2(config-if)# shut
switch2(config-if)# description Portchannel 2 Switch 2
switch2(config-if)# switchport trunk allowed vlan 1,7,10
switch2(config-if)# switchport mode trunk
switch2(config-if)# channel-protocol lacp
switch2(config-if)# channel-group 2 mode active
switch2(config-if)# no shut
switch2(config-if)# end
switch2#wr

* Lưu ý *
---> Bắt buộc phải shutdown các port trước khi cấu hình, nếu không sẽ gây ra lỗi. Các port phải cùng tốc độ (Speed/Duplex)
---> Có thể gắn card HWIC-4ESW, EHWIC-4ESG, NIM-ES2-4, .... trên router, rồi nối các port trên card vào switch để cân bằng tải.
---> Có thể kết hợp cấu hình etherchannel để cân bằng tải và dự phòng giữa switch Cisco với server.
---> Mỗi chip xử lý trên switch gộp 8ports lại và xử lý cùng 1 chip, do đó, để cân bằng tải hiệu quả, thường tính port theo nguyên tắc 8+. VD: Port 1 và port 9 thành 1 group, Port 10 và 18 thành 1 group,...

---> Cách cấu hình Router Cisco chạy dual WAN session based <---

Sơ đồ như sau

Cổng G0/1: Nối với đường VNPT, username aaaa / password bbbb
Cổng G0/2: Nối với đường FPT, username cccc / password dddd
Cổng G0/0: Nối đến switch, IP: 192.168.1.1 / Netmask 255.255.255.0
---> Mục đích: Chạy 1 lúc cả 2 đường truyền, khi một trong hai đường truyền gặp trục trặc, sẽ chuyển sang đường truyền còn lại mà không gây gián đoạn.

Tiến hành cấu hình như sau

router> en
Nhập password nếu có
router# conf t

Cấu hình cổng LAN

router(config)#int g0/0
router(config-if)# ip add 192.168.1.1 255.255.255.0
router(config-if)# no shut
router(config-if)# ip nat inside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# ip virtual-reassembly
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

Cấu hình cổng kết nối modem VNPT

router(config)# interface g0/1
router(config-if)# description $VNPT$
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 1
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

Cấu hình cổng kết nối modem FPT

router(config)# interface g0/2
router(config-if)# description $FPT$
router(config-if)# no ip address
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# pppoe en group global
router(config-if)# pppoe-client dial-pool-number 2
router(config-if)# no shut
router(config-if)# no cdp enable
router(config-if)# duplex auto
router(config-if)# speed auto
router(config-if)# exit

Tiến hành quay số pppoe đường VNPT

router(config)# int dialer 1
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 1
router(config-if)# dialer-group 1
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username aaaa password 0 bbbb
router(config-if)# ppp chap hostname aaaa
router(config-if)# ppp chap password bbbb
router(config-if)# exit

Tiến hành quay số pppoe đường FPT

router(config)# int dialer 2
router(config-if)# ip add nego
router(config-if)# ip mtu 1454
router(config-if)# ip nat outside
router(config-if)# ip nat enable
router(config-if)# ip tcp adjust-mss 1400
router(config-if)# encapsulation ppp
router(config-if)# dialer pool 2
router(config-if)# dialer-group 2
router(config-if)# no cdp en
router(config-if)# ppp authentication pap chap callin
router(config-if)# ppp pap sent-username cccc password 0 dddd
router(config-if)# ppp chap hostname cccc
router(config-if)# ppp chap password dddd
router(config-if)# exit

Tạo route-map cho 2 đường

router(config)# route-map VNPT permit 10
router(config-route-map)# match ip address 1
router(config-route-map)# match interface dialer1
router(config-route-map)# exit
router(config)#route-map FPT permit 10
router(config-route-map)# match ip address 1
router(config-route-map)# match interface dialer2
router(config-route-map)# exit

Tạo dải IP cho phép, NAT và route theo route-map đã cấu hình phía trên

router(config)# access-list 1 permit 192.168.1.0 0.0.0.255
router(config)# ip route 0.0.0.0 0.0.0.0 dialer1 name VNPT
router(config)# ip route 0.0.0.0 0.0.0.0 dialer2 name FPT
router(config)# ip nat inside source route-map VNPT interface dialer1 overload
router(config)# ip nat inside source route-map FPT interface dialer2 overload

Tạo pool DHCP để cấp IP cho các thiết bị bên dưới

router(config)# service dhcp
router(config)# ip dhcp pool 1
router(dhcp-config)# network 192.168.1.0 255.255.255.0
router(dhcp-config)# default-router 192.168.1.1
router(dhcp-config)# dns-server 208.67.220.220 208.67.222.222
router(dhcp-config)# exit

Tạo dải IP loại trừ

router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.20
router(config)# exit
router# wr

Lưu ý

---> Cấu hình trên sử dụng 1 lúc hai đường truyền. Tuy nhiên, khi speedtest không cộng gộp băng thông như Router Draytek hay Mikrotik.
---> Khuyến cáo chỉ nên sử dụng 2 đường WAN đối với cách cấu hình này, đã test và chạy ổn. Khi có nhiều hơn 3 đường WAN, bảng định tuyến lúc này sẽ trở nên rối rắm, router mất một khoản thời gian để so sánh và đối chiếu, nên sẽ làm mạng chạy không được mượt.
---> Đối với mạng VNPT, cần tắt modem nhà mạng tầm 20-30s, sau đó mở lại để nhận IP pppoe.
---> Đối với mạng FPT, cần gọi lên tổng đài để xác thực MAC-Address.
---> Đối với mạng Viettel, lúc trước cần phải tag VLAN 35, nhưng sau này họ đã bỏ tag, nên trước khi cấu hình, cần phải hỏi rõ để cấu hình cho chính xác.

---> Hướng dẫn cấu hình Load Balancing trên Router Cisco theo phương thức Failover <---

Sơ đồ như sau

ISP1: FPT
Tên đường truyền: aaaa Password: bbbb
Kết nối port G0/1
ISP2: VNPT
Tên đường truyền: cccc Password: dddd
Kết nối port G0/2

Local LAN: 192.168.1.1 / Netmask: 255.255.255.0
Kết nối port G0/0

Mục đích

Sử dụng đường FPT là đường sử dụng chính, VNPT là đường dự phòng. Khi đường FPT down thì ngay lập tức chuyển sang đường VNPT. Khi đường FPT up trở lại thì chuyển sang đường FPT, còn đường VNPT quay trở lại trạng thái chờ.

Tiến hành cấu hình như sau

---> Mình bỏ qua khúc quay số pppoe và tạo pool DHCP vì đã có tài liệu hướng dẫn, các bạn có thể tham khảo ở bài quay số pppoe và tạo pool DHCP ở các phần trên.

---> Sau khi tiến hành quay số pppoe xong, chúng ta tiếp tục cấu hình như sau:

Tạo access-list cho phép NAT

router(config)# ip access-list standard ACL-DNAT
router(config-ext-nacl)# permit 192.168.1.0 0.0.0.255
router(config-ext-nacl)# exit

Tạo route-map để xác định bảng định tuyến

router(config)# route-map RM-NAT-ISP01 10 ---> Số 10 là số thứ tự
router(config-route-map)# match ip add ACL-DNAT
router(config-route-map)# match int dialer 1
router(config-route-map)# exit
router(config)# route-map RM-NAT-ISP02 10
router(config-route-map)# match ip add ACL-DNAT
router(config-route-map)# match int dialer 2
router(config-route-map)# exit

Tiến hành NAT theo bảng định tuyến

router(config)# ip nat inside source route-map RM-NAT-ISP01 int dialer 1 overload
router(config)# ip nat inside source route-map RM-NAT-ISP02 int dialer 2 overload

Tạo ip sla để theo dõi tình trạng dialer

router(config)#ip sla 20 ---> 20 là số thứ tự
router(config-ip-sla)# icmp-echo 8.8.8.8
router(config-ip-sla)# threshold 1 ---> nếu 1 lần ping thất bại thì tiến trình track sẽ rơi vào trạng thái down
router(config-ip-sla)# timeout 200 ---> kể từ lúc gửi gói tin ping icmp-echo, sau 200 ms mà không nhận được hồi đáp icmp-reply thì được tính là một lần ping thất bại
router(config-ip-sla)# frequency 1 ---> ping định kỳ 1 giây một lần tới địa chỉ 8.8.8.8
router(config-ip-sla)# exit
router(config)# ip sla schedule 20 life forever start-time now
router(config)# track 1 ip sla 20 reachability ---> Số 1 là số thứ tự, số 20 là số ip sla đã khai báo bên trên
router(config-track)# delay down 0 up 0 ---> Downtime 0s, sau 0s sẽ quay về lại Dialer1 để định tuyến, khi phát hiện Dialer 1 ở trạng thái up
router(config-track)# exit

Track định tuyến dialer theo IP SLA đã thiết lập

router(config)# ip route 0.0.0.0 0.0.0.0 dialer 1 track 1
router(config)# ip route 0.0.0.0 0.0.0.0 dialer 2 2 ---> So 2: là số thứ tự

Lưu ý
1. Router Cisco cần có license DATA, hoặc SEC để có thể sử dụng được IP SLA. Riêng đối với các dòng ISR 4K thì cần license App hoặc SEC. Các dòng router đời cũ thì cần tối thiểu advservices IOS.
2. Có thể thay IP 8.8.8.8 bằng các IP khác. VD: 1.1.1.1 , 208.67.222.222 , ...

***** Tiếp theo ở post số 19 và 20 *****

Riêng firewall thì phải cụ thể từng tình huống, do liên quan license này nọ.

Thím nào có thắc mắc, hoặc cần hỏi gì thì mình sẽ trả lời trong này.

:love::love::love::love::love::love:
 
Last edited:

mooney583377

Senior Member
Chào các thím,

Chẳng qua là dịch rảnh rỗi quá, nên mình lập topic này, chia sẻ về cấu hình các thiết bị Cisco: Router, Switch, Controller, AP.

Riêng firewall thì phải cụ thể từng tình huống, do liên quan license này nọ.

Thím nào có thắc mắc, hoặc cần hỏi gì thì mình sẽ trả lời trong này.

:love::love::love::love::love::love:
Có con san switch license 12 port mặc định, có cheat lên full 48 port đc k bác :3
 

trakimanhminh

Đã tốn tiền
Giá bao nhiêu.

Tùy theo mỗi end user (Bên này hay gọi là EU), tùy deal sẽ có các mức discount khác nhau, bên mình thì thường thấp nhất là 50% theo giá list. Có những deal sẽ có mức discount tới 90% (nhưng sẽ tùy vào sản phẩm). Các dòng Small Business (SG, SF, CBS, RV,...) thường có mức discount thấp hơn các dòng Router hay Catalyst lớn.

Đối với các dòng đã qua sử dụng thì giá rất tốt.

Có con san switch license 12 port mặc định, có cheat lên full 48 port đc k bác :3

Mã SAN của bạn là gì nữa, có vẻ bạn đang sử dụng là Nexus 5020 đúng không?
Cheat license của Cisco gần như là không thể (trừ 1 số dòng ASA đời cũ).
Bạn chỉ có thể mua với giá tốt tùy dealer thôi.
 

TomDAce

Senior Member
Tùy theo mỗi end user (Bên này hay gọi là EU), tùy deal sẽ có các mức discount khác nhau, bên mình thì thường thấp nhất là 50% theo giá list. Có những deal sẽ có mức discount tới 90% (nhưng sẽ tùy vào sản phẩm). Các dòng Small Business (SG, SF, CBS, RV,...) thường có mức discount thấp hơn các dòng Router hay Catalyst lớn.

Đối với các dòng đã qua sử dụng thì giá rất tốt.
Giá bao nhiêu. 1 triệu, 2 triệu hay 50 triệu, 100 triệu.

Anh đang nói cái gì thế.
 

trakimanhminh

Đã tốn tiền
Giá bao nhiêu. 1 triệu, 2 triệu hay 50 triệu, 100 triệu.

Anh đang nói cái gì thế.

Mình đang nói tổng quát, trên phương diện nhà cung cấp và giá cho các dự án.

Còn anh muốn mã cụ thể thì đưa ra, rồi mình báo cho! Cisco có hơn cả ngàn mã sản phẩm, giá 1 triệu cũng có, 2 triệu cũng có, 50 triệu cũng có, 100 triệu cũng có, 1 tỷ cũng có,...
 

rjshkkj

Senior Member
Có bác nào biết nhà phân phối nào của CISCO không, đang có dự án cần nhập ít switch CISCO mà không biết ở đâu cho giá tốt.
Switch Unmanaged thôi, chuẩn giga loại 24 port, 16 và 8 port
 

trakimanhminh

Đã tốn tiền
Có bác nào biết nhà phân phối nào của CISCO không, đang có dự án cần nhập ít switch CISCO mà không biết ở đâu cho giá tốt.
Switch Unmanaged thôi, chuẩn giga loại 24 port, 16 và 8 port

Bên mình có phân phối luôn, bạn cho mình danh mục sản phẩm, mình sẽ gửi báo giá cho bạn. Mà mấy dòng Unmanaged thì giá discount không nhiều.

CISCO nó là ma trận license để lụm $$$ của doanh nghiệp, trên voz chắc chả thím nào dám đụng vào nó vì cái $$$ ma trận license đó :LOL:

Đúng rồi bạn, ngay cả mình bán các thiết bị Cisco, đôi khi còn nhức đầu về vấn đề license của nó đây.

Trong phạm vi topic và kinh nghiệm thực tế, mình sẽ giải đáp các thắc mắc của các bạn về thiết bị Cisco chính xác nhất có thể :)
 

mooney583377

Senior Member
Tùy theo mỗi end user (Bên này hay gọi là EU), tùy deal sẽ có các mức discount khác nhau, bên mình thì thường thấp nhất là 50% theo giá list. Có những deal sẽ có mức discount tới 90% (nhưng sẽ tùy vào sản phẩm). Các dòng Small Business (SG, SF, CBS, RV,...) thường có mức discount thấp hơn các dòng Router hay Catalyst lớn.

Đối với các dòng đã qua sử dụng thì giá rất tốt.



Mã SAN của bạn là gì nữa, có vẻ bạn đang sử dụng là Nexus 5020 đúng không?
Cheat license của Cisco gần như là không thể (trừ 1 số dòng ASA đời cũ).
Bạn chỉ có thể mua với giá tốt tùy dealer thôi.
em đang xài con này
cisco MDS 9148S
mã này chắc k phải đồ cũ rồi, vì mới mua năm 2020, giờ cần mở rộng thêm port. nếu cheat đc thì đỡ phải trình sếp :shame::shame:
 

trakimanhminh

Đã tốn tiền
em đang xài con này
cisco MDS 9148S
mã này chắc k phải đồ cũ rồi, vì mới mua năm 2020, giờ cần mở rộng thêm port. nếu cheat đc thì đỡ phải trình sếp :shame::shame:

Mình chưa đụng mã này nên không rõ. Mấy dòng này sử dụng DS-SFP thì phải, tầm tháng trước, bên Inter.... mới mua.

Trong màn hình global mode, bạn xem thử giúp mình có câu lệnh này không nhé:

Switch#license right-to-use ?

Nếu có, thì bạn có thể kích hoạt mà không cần phải mua license.
 

mooney583377

Senior Member
Mình chưa đụng mã này nên không rõ. Mấy dòng này sử dụng DS-SFP thì phải, tầm tháng trước, bên Inter.... mới mua.

Trong màn hình global mode, bạn xem thử giúp mình có câu lệnh này không nhé:

Switch#license right-to-use ?

Nếu có, thì bạn có thể kích hoạt mà không cần phải mua license.
k có rồi bác ạ
Code:
# l?
           ^
% Invalid command at '^' marker.
 

trakimanhminh

Đã tốn tiền
k có rồi bác ạ
Code:
# l?
           ^
% Invalid command at '^' marker.


À mình nhầm xíu, vậy bạn thử vào config mode, rồi gõ lệnh

switch(config)# license ?

Xem có hiện thông tin gì không nhé!

Với license này hiện tại bên mình đang bán là 6.000.000 VNĐ nhé. Mã như sau:

M9148S-DPL12P8G
Hoặc M9148S-DPL12PSG
 
Last edited:

mooney583377

Senior Member
À mình nhầm xíu, vậy bạn thử vào config mode, rồi gõ lệnh

switch(config)# license ?

Xem có hiện thông tin gì không nhé!

Với license này hiện tại bên mình đang bán là 6.000.000 VNĐ nhé. Mã như sau:

M9148S-DPL12P8G
Hoặc M9148S-DPL12PSG
Code:
# license ?
  grace-period  Configure grace period support for licenses
  smart         Smart license related commands
2 mã này ốp phát là có luôn 48 port à bác
M9148S-DPL12P8G
Hoặc M9148S-DPL12PSG
 

trakimanhminh

Đã tốn tiền
Code:
# license ?
  grace-period  Configure grace period support for licenses
  smart         Smart license related commands
2 mã này ốp phát là có luôn 48 port à bác

Vậy là Switch này không hỗ trợ evaluation rồi. Bạn có thể down tạm xuống bản 6.2(33) xem có hỗ trợ nhiều hơn không không nhé.

Mỗi license là cho 12 ports nhé bạn.

M9148S-DPL12P8G: License này là dùng để sử dụng Module DS-SFP 8Gb
M9148S-DPL12PSG: License này là dùng để sử dụng Module DS-SFP 16Gb

Nếu bạn cần sử dụng đủ 48ports, thì phải mua 3 cái license :)
 

mooney583377

Senior Member
Vậy là Switch này không hỗ trợ evaluation rồi. Bạn có thể down tạm xuống bản 6.2(33) xem có hỗ trợ nhiều hơn không không nhé.

Mỗi license là cho 12 ports nhé bạn.

M9148S-DPL12P8G: License này là dùng để sử dụng Module DS-SFP 8Gb
M9148S-DPL12PSG: License này là dùng để sử dụng Module DS-SFP 16Gb

Nếu bạn cần sử dụng đủ 48ports, thì phải mua 3 cái license :)
ok. em cám ơn bác đã thông não cho em :D
 

trakimanhminh

Đã tốn tiền
** Video hướng dẫn cấu hình Linksys **

---> Hướng dẫn cấu hình wifi Linksys WRT32X <---


---> Hướng dẫn cấu hình wifi Linksys WRT1900AC / WRT1900AC V2 / WRT1900 ACS <---


---> Hướng dẫn stack trên Switch Cisco 3650 / 3850 Series <---

Có 2 loại stack như sau

1. Stack nguồn
- Mục đích: Khi nguồn của switch bị lỗi thì sẽ lấy nguồn của switch còn lại để chạy, đảm bảo không bị rớt nguồn, gây gián đoạn trong quá trình vận hành.
- Switch 3850 Series hỗ trợ.
- Switch 3650 Series không hỗ trợ.
- Thiết bị cần: Cáp Cisco CAB-SPWR-30CM hoặc CAB-SPWR-150CM. Gắn 2 nguồn trên mỗi switch.

2. Stack Data (Hay còn gọi là Stack Wise)
- Mục đích: Gom các switch lẻ thành 1 switch thống nhất, quản trị trên giao diện của 1 switch.
- Switch 3850 hỗ trợ, chỉ cần mua thêm cáp stack gắn vào là được
- Switch 3650 hỗ trợ, tuy nhiên bộ Stack Data là phần mua riêng, không đi kèm với sản phẩm. Mã của nó là C3650-STACK-KIT.
- Tối đa có thể gắn 8 thiết bị stack với nhau.

3. Cơ chế bầu chọn switch Master và Member

  • Nếu switch mở lên đồng thời, và bầu chọn theo cơ chế tự động, chưa có cấu hình, thì switch có địa chỉ MAC thấp hơn sẽ được lựa chọn thành Master.
  • Nếu switch mở nguồn theo thứ tự, và bầu chọn theo cơ chế tự động, chưa có cấu hình, thì switch uptime trước sẽ được lựa chọn thành Master.
  • Nếu switch mở đồng thời, bầu chọn theo cơ chế tự động, thì switch được cấu hình sẵn sẽ trở thành switch Master (Switch chưa được cấu hình sẽ trở thành Member).
  • Hoặc chúng ta có thể chỉ định switch nào thành Master bằng cách chỉnh priority. Switch nào có priority cao hơn sẽ trở thành switch Master. Câu lệnh như sau:

switch# show switch ---> Xác định tên switch
Switch/Stack Mac Address : d8b1.9056.5f80
H/W Current
Switch# Role Mac Address Priority Version State
----------------------------------------------------------
*1 Master d8b1.9056.5f80 10 3 Ready
2 Member f8db.4590.9f99 1 3 Ready

---> Ở đây có thể thấy, Switch 1 đang làm Master, địa chỉ MAC: d8b1.9056.5f80, priority 10 (Cao nhất hiện tại nên được bầu làm Master), Switch 2 đang làm Member, địa chỉ MAC: f8db.4590.9f99, priority 1 (Thấp hơn so với switch 1, nên được bầu chọn làm Member).

switch(config)# switch 2 priority 15 ---> Đổi thứ tự Priority của Switch
switch(config)# exit
switch# wr
switch# reload ---> Khi thay đổi priority, buộc phải khởi động lại để câu lệnh có tác dụng trong việc bầu chọn Master và Member.
---> Lúc này, Switch 2 sau khi reload, sẽ có priority là 15, cao hơn so với Switch 1, do đó sẽ được bầu chọn làm Master. Switch 1 lúc này, do có priority 10, nên quay về làm Member.

4. Đặt lại tên Switch

Tiếp tục ở VD trên, vì Switch 2 lúc này đã trở thành Master, nhưng nhìn tên là "Switch 2", nên dễ gây lầm lẫn. Do đó, để được thuận mắt, chúng ta có thể đổi tên lại các switch để dễ nhìn hơn. Tuy nhiên, việc này không khuyến khích, vì có thể gây ra một số lầm lẫn, nên cần phải cẩn trọng khi làm.

switch(config)# switch 2 renumber 3 ---> Mượn tạm số 3
switch(config)# do reload slot 2

---> Sau khi switch 2 reload xong, giờ chuyển thành switch number 3. Giờ tiếp tục chuyển switch number 1 thành switch number 2

switch(config)# switch 1 renumber 2
switch(config)# do switch 1 reload

---> Sau khi switch 1 reload xong, giờ chuyển thành switch number 2. Giờ tiếp tục chuyển switch number 3 thành switch number 1.

switch(config)# switch 3 renumber 1
switch(config)# do switch 3 reload
switch(config)# exit
switch# wr

Các lưu ý trước khi stack

- Các switch phải cùng license với nhau. Ở dòng switch Cisco 3650/3850 Series, chúng ta có thể nhận biết license bằng ký hiệu ở đuôi của thiết bị (-L: Lanbase, -S: Ipbase, -E: Ipservices)
VD: WS-C3650-24TS-L: Thiết bị này có đuôi tận cùng là -L, nên license của nó là Lanbase
WS-C3850-24T-S: Thiết bị này có đuôi tận cùng là -S, nên license của nó là Ipbase
  • Các switch phải cùng IOS với nhau. Ngoài ra, từ dòng switch Cisco 3650/3850 Series trở đi, IOS mặc dù cùng Version, nhưng được chia ra làm 2 phiên bản, là INSTALL MODE và BUNDLE MODE. Do đó, chúng ta cần phải đặc biệt chú ý ở điểm này để convert cho trùng nhau thì mới có thể stack thành công.
  • Các switch phải được reset trắng cấu hình trước khi stack. Trường hợp switch trong hệ thống bị lỗi, cần thay thế, thì chỉ cần reset trắng switch cần thay thế và gắn vào, lúc bấy giờ, cấu hình sẽ đổ trực tiếp từ hệ thống xuống. (Vẫn yêu cầu switch thay thế trùng IOS và license).

---> Hướng dẫn cấu hình Dynamic VPN ( Viết tắt: DMVPN) <---

***** Hướng dẫn cấu hình DMVPN *****

-> Router 1: Router chính, hay còn gọi là Hub
+) IP tĩnh: a.a.a.a, IP local: 10.10.10.1/24
+) Tunnel 1: 172.16.1.1
-> Router 2: Router kết nối đến, hay còn gọi là Spoke
+) IP động, IP local: 192.168.1.1/24
+) Tunnel 1: 172.16.1.2
-> Tiến hành cấu hình như sau:

***** Router 1 *****
Tigernet> en
Tigernet# conf t
Tigernet(config)# ip classless
Tigernet(config)# interface Tunnel 1
Tigernet(config-if)# description DM_VPN
Tigernet(config-if)# ip address 172.16.1.1 255.255.255.0
Tigernet(config-if)# no ip redirects
Tigernet(config-if)# no ip next-hop-self eigrp 10
Tigernet(config-if)# no ip split-horizon eigrp 10
Tigernet(config-if)# ip nhrp authentication Tigernet
Tigernet(config-if)# ip nhrp network-id 1
Tigernet(config-if)# ip nhrp redirect
Tigernet(config-if)# tunnel source Dialer1
Tigernet(config-if)# tunnel mode gre multipoint
Tigernet(config-if)# ip tcp adjust-mss 1330
Tigernet(config-if)# exit
Tigernet(config)# ip route 192.168.1.0 255.255.255.0 172.16.1.2
Tigernet(config)# exit
Tigernet# wr

***** Router 2 *****
Spoke 2> en
Spoke 2# conf t
Spoke 2(config)# ip classless
Spoke 2(config-if)# interface Tunnel1
Spoke 2(config-if)# description DM_VPN
Spoke 2(config-if)# ip address 172.16.1.2 255.255.255.0
Spoke 2(config-if)# no ip redirects
Spoke 2(config-if)# ip nhrp authentication Tigernet
Spoke 2(config-if)# ip nhrp map multicast dynamic
Spoke 2(config-if)# ip nhrp map 172.16.1.1 113.161.40.153
Spoke 2(config-if)# ip nhrp map multicast 113.161.40.153
Spoke 2(config-if)# ip nhrp network-id 1
Spoke 2(config-if)# ip nhrp nhs 172.16.1.1
Spoke 2(config-if)# tunnel source Dialer1
Spoke 2(config-if)# tunnel mode gre multipoint
Spoke 2(config-if)# ip tcp adjust-mss 1330
Spoke 2(config-if)# exit
Spoke 2(config)# ip route 10.10.10.0 255.255.255.0 172.16.1.1
Spoke 2(config)# exit
Spoke 2# wr
 
Last edited:

trakimanhminh

Đã tốn tiền
* Cách chuyển AP Cisco qua chế độ Stand Alone *

* Chuyển AP Cisco qua chế độ Stand Alone *

B1: Đảm bảo các kết nối sau:
  • Tải file IOS về một thư mục nào đó.
  • Máy tính dùng cổng RJ45 kết nối đến AP (Trên máy tính đặt IP: 10.10.10.10 / Netmask 255.255.255.0 gateway 10.10.10.1)
  • Tải chương trình tftp về, trỏ đến thư mục chứa file ios, trỏ đến IP của cổng LAN.
  • Tải putty về
  • Console nối từ AP đến máy tính
B2: Thực hiện các bước sau:
  • Mở AP lên, giữ nút mode trong vòng 30-40s (hoặc 40-60s)
  • Sau khi vào được ROMMON, tiếp tục cấu hình như sau:
ap: flash_init
ap: format flash:
chọn ---> y
---> Bước này chờ tầm 5p
ap: IP_ADDR=10.10.10.11
ap: NETMASK=255.255.255.0
ap: DEFAULT_GATEWAY=10.10.10.1
ap: ether_init
ap: tftp_init
ap: tar -xtract tftp://10.10.10.10/tên file flash:
sau đó chờ load IOS, sau khi load xong gõ lệnh reset (hoặc reload)

Lưu ý:
  • Có 1 số dòng AP đời cũ, sau khi gõ các lệnh trên xong, nhưng khi copy từ tftp sẽ báo lỗi time out, lúc này chỉ cần restart lại AP, sau đó gõ lại các câu lệnh như trên là được.
  • Các file IOS có ký hiệu K9W7.
  • Cách làm này áp dụng với các AP Series: 1140, 1240, 1250, 1130, 3502, 1600, 2600, 3600, 1700, 2700, 3700 series.
  • Các dòng đời sau, sử dụng Mobility Express sẽ có cách cấu hình khác. VD: 1800, 2800, 3800, 4500, 9300,...
Video hướng dẫn:


* Cấu hình AP Cisco phát wifi sau khi chuyển qua chế độ Stand Alone *

-> Dia chi AP: 192.168.1.10
-> Dia chi Default Gateway Router: 192.168.1.1
-> SSID: Tigernet_2.4Ghz va Tigernet_5Ghz
-> Password: Tigernet
-> Tien hanh cau hinh nhu sau:

ap> en
Nhập password: Cisco
ap# conf t
ap(config)# int bv1
ap(config-if)# ip add 192.168.1.10 255.255.255.0 ---> Đặt địa chỉ IP cho AP
ap(config-if)# exit
ap(config)# ip default-gateway 192.168.1.1 ---> Đây là địa chỉ IP của router
ap(config)# dot11 ssid Tigernet_2.4Ghz ---> Tên wifi sẽ phát
ap(config-ssid)# auth open
ap(config-ssid)# auth key wpa
ap(config-ssid)# wpa-psk ascii Tigernet ---> Password wifi
ap(config-ssid)# guest-mode
ap(config-ssid)# exit
ap(config)# dot11 ssid Tigernet_5Ghz
ap(config-ssid)# auth open
ap(config-ssid)# auth key wpa
ap(config-ssid)# wpa-psk ascii Tigernet
ap(config-ssid)# guest-mode
ap(config-ssid)# exit
ap(config)# int d0
ap(config-if)# encryption mode ciphers aes-ccm
ap(config-if)# ssid Tigernet_2.4Ghz
ap(config-if)# channel 10 ---> Gán channel cho SSID
ap(config-if)# no shut
ap(config-if)# exit
ap(config)# int d1
ap(config-if)# encryption mode ciphers aes-ccm
ap(config-if)# ssid Tigernet_5Ghz
ap(config-if)# channel 40
ap(config-if)# no shut
ap(config-if)# end
ap#wr

Lưu ý:
  • Password sau khi reset về mặc định là Cisco.
  • Chúng ta có thể kết nối với máy tính, dùng IP: 192.168.1.10 để vào giao diện web interface của AP, username và password mặc định là Cisco/Cisco
  • Một số AP chỉ có 1 băng tầng, do đó, chúng ta cần kiểm tra trước khi cấu hình, bằng cách dùng câu lệnh " show ip interface bri" , nếu chỉ có 1 Dot11Radio, nghĩa là nó chỉ có 1 băng tầng, và thường mặc định là 2.4Ghz.
  • Đối với băng tầng 5Ghz, thường mặc định là 20Mhz, nếu bạn muốn tăng lên thì dùng 1 trong 2 câu lệnh sau để chỉnh sửa:
  • - ap(config)# int d1
  • - ap(config-if)# channel width 40-below ---> Phát ở 40Mhz hoặc 20Mhz
    hoặc ap(config-if)# channel width 40-above ---> Phát ở 40Mhz hoặc trên đó
  • Cách làm này áp dụng với các AP Series: 1140, 1240, 1250, 1130, 3502, 1600, 2600, 3600, 1700, 2700, 3700 series.
  • Các dòng đời sau, sử dụng Mobility Express sẽ có cách cấu hình khác. VD: 1800, 2800, 3800, 4500, 9300,...
 
Last edited:
Top